PDA

View Full Version : New interface for editing posts and uploads - tabbed for easier navigation!


Nysha
28th Mar 2011, 12:44 AM
Thanks to the ministrations of Delphy, we're very proud to show off the new, improved, tabbed interface for editing posts and uploads!

The old interface involved, basically, a hell of a lot of scrolling - especially on uploads, there were a load of options and sections, and it could be rather a challenge to find the one you were after. The new interface organises all these options neatly, so you can quickly flip between (largely :p ) logically named tabs to find what you're after - plus we have a new AJAX preview, which doesn't require a page reload.

For the technically-minded, you've probably already figured out that the old page was essentially the basic vBulletin editpost.php, with the various fancy hacks and fields that we've added over the years tacked on. The default editpost.php wasn't designed to handle nearly so much stuff, hence the clunkiness. The new interface is an adaptation of that, custom designed and coded by Delphy.

http://thumbs.modthesims.info/getimage.php?file=1186497

D has also updated the Quick Reply box to match - no pics of that, you can scroll down and see it yourself :p .

We hope you all like this new interface, and find it easier to use (once you get used to it). :) Any comments are very welcome!

Some of you may have already noticed this - as well as having noticed that for a while the submit button didn't work, and for some people nothing showed up at all. Everything should be fixed now; any lingering issues will vanish as the caches refresh. :)

CatOfEvilGenius
28th Mar 2011, 3:28 AM
Once again, thank you, Delphy. :)

NixNivis
28th Mar 2011, 3:54 AM
*pets the shiny new interface*

THANK YOU for this! This will make editing uploads so much quicker and easier! :)

Nalia
28th Mar 2011, 11:47 AM
Nice improvements. Thank you, Delphy. *thumbs up*

Nouk
28th Mar 2011, 5:45 PM
I love it :) Good job and thanks!

maybesomethingdunno
28th Mar 2011, 10:36 PM
I really like it. :)

I've noticed that it seems either all text is bold in the text area (and in the preview) or the preview view doesn't render the bold bbcode.

"Test" - not in bold
"Test" - bold
Both "Test"s look the same in the preview.

ETA: Once posted, it looks as it should.

lilyandsnuggles2
28th Mar 2011, 10:50 PM
It looks much more modern. Thank you Delphy! :D

Simonut
29th Mar 2011, 3:05 AM
Very nice something new and oh do we LOVE new toys. :new:

Purplepaws
29th Mar 2011, 11:30 AM
Looks great! Thanks a lot, Delphy! :up:

Tashiketh
29th Mar 2011, 12:19 PM
Maybesomethingdunno: Looks fine here. Does it work in other browsers?

maybesomethingdunno
29th Mar 2011, 7:01 PM
In IE8, it appears to be italics.

What I see:
http://img859.imageshack.us/img859/1412/screenshot001m.png
http://img217.imageshack.us/img217/5976/screenshot002oq.png

Tashiketh
29th Mar 2011, 7:55 PM
I'm in IE8 now, and bold seems to work, and I don't see italics...

I also was in FF4 earlier and it was fine too.... So... I dunno... it's weird.

Test

Test

Internet Explorer 8.

http://www.modyourpanties.com/hosting/26810_110329205455ie8_quickreply.PNG

http://www.modyourpanties.com/hosting/26811_110329205615ie8_quickreply2.PNG

Nysha
29th Mar 2011, 8:00 PM
IE still doesn't have CSS rounded corners? :/

maybesomethingdunno
29th Mar 2011, 8:18 PM
Indeed weird. Everything seems to be fine once posted, though. It's just my pre-posted text. When I click the "Go Advanced" button, everything is as it should be as well.

I don't know why I'd be the only one. I'm personally fine with the pseudo emphasis in the Quick Reply box (even if it's not what is intended). Just thought I'd give a head-up about it. :)

nightwitch
4th Apr 2011, 9:03 AM
hmm this sounds inrest