Replies: 1 (Who?), Viewed: 324 times.
Test Subject
Original Poster
#1 Old 31st May 2022 at 1:23 AM
2t4 mesh showing as invisible
Hi all.

I'm pretty new to making 2t4 conversions. This is one of my first projects, and I've been following this tutorial to convert a pair of pants from Sims 4 Cool Kitchen Stuff into Sims 2. I've been following the tutorial pretty much to a T, supplementing it with other various tutorials online for anything that's unclear (not much). It's worked out very well thus far, I was getting super proud of myself seeing the whole thing coming together, until...I put the mesh into the game, right at the end, and it's invisible. No legs, no feet, no nothing.

I'm decently familiar with how Sims 2 reads things technically, so my guess is that the mesh just somehow isn't being properly linked. I've gone through the entire process of creating the mesh .package file and linking it to the recolor about two and a half times already, I've retried just about every step that there is, and nothing has worked. I do recall Milkshape giving me a message that said there were some unassigned bones when exporting the mesh as a .simpe file, but I'm not sure that something like that would cause this issue. I've also read another thread where someone else had the same problem, but it was related to using an adult skeleton on a child mesh, which I did not do. I did have some problems with the skeleton at one point, but I followed someone else's instructions to fix it (importing a different identically-functional skeleton and re-importing the body and not including the skeleton). I can elaborate more on what I did to fix that and dig up the thread if needed.

I've included the files I've been experiencing issues with in a .zip linked. If anyone is able to check them that would be great. Thank you!
Screenshots
Download - please read all instructions before downloading any files!
File Type: zip Mesh and file.zip (443.0 KB, 2 downloads)
Advertisement
Mad Poster
#2 Old 4th Jun 2022 at 6:17 PM
You're lacking the second subset in the PropertySet, and a second texture/TXMT (can be an empty one).

All the subset names have to match between the mesh and PropertySet, so you can't have the subset in the mesh named "body" while it's called "bottom" in the PropertySet.

Stick to "bottom" if you're making a bottom (you can use "bottom2" or similar for a group that's UVmapped differently than a TS2 mesh, for instance 4t2/3t2).

The mesh seems to have the entire body attached in the "body" group - make sure to remove everything not needed for the bottom before exporting (everything that's not showing, so keep just the exposed calves/ankles).

Also, the pants don't appear to have been given bone assignments (or morphs), so you probably have to do those steps again.
Back to top