Replies: 745 (Who?), Viewed: 361970 times.
Page 30 of 30
Field Researcher
#726 Old 16th Nov 2017 at 5:53 AM
Originally Posted by DeeDawg

I would love to finish that one, if only I could find the time. Not sure it's the smartest idea to let anyone know about it, but what the hell - let the nagging begin haha.


Now I'm anxious, DeeDawg. I shall be your greatest "nagger" until the moment you provide a download for your core. But after that, I shall love your talents all the more, and sing your praises to every gamer on MTS' forum floor!

I promise, I swear, so get crackin! The sooner the bett-OR! LOL


Some people never go crazy. What truly horrible lives they must live.
Lab Assistant
#727 Old 13th May 2018 at 2:40 PM
Hello everybody! Not sure if this thread is still on, but well... I post because I have a consult of sorts to do. Here's the thing:

I wanted to make my "own" characters, so I took one of the random NPC that keep respawning. I wanted him/her to wear one of the exclusive hero clothes, so I used this Core to set a proffession on them.
But, then I couldn't change their title from whatever knight or bard to what I intended to name them.
So I made them "Retire from proffession" because I don't want an army of spies or merchants, BUT then they lost their exclusive hero clothes after a little while.

This is the issue. Is there a way to make this two things work together, keeping the clothes and changing their title? Please, any clue will be appreciated...

*P.S. Oh, before I forget... I cannot either change the proffession to peteran or jacoban. I understand why not to monarch, of course, but why there are only six options available?
Test Subject
#728 Old 17th Jun 2018 at 4:20 PM
Hopefully some can help but I know this mod is old. I have bin having a problem with my wizard hero they can not prepare basic spells e.g flare I can do deadly arrow magical tune and vanish but no others. When I remove mod I still get stuck with magical tune and vanish and cannot do others and starting a new game does not help
Test Subject
#729 Old 28th Oct 2019 at 10:32 PM
well i am pretty certain there wont be any replies and the key modders here (as far as i know) have been gone for a good long while
but here go's nothing

much like Revan233 above me has stated I too have the issue that my Wizard can only use Deadly Arrow (and nothing else atm) he is lvl 2 but nothing of the lvl 1 spells are an option, using the runes ends up as failure as well
I noticed when i gave my monarch magic he could use multiple spells but no deadly arrow
seems the game has split the magic options in some kind of way

is there anyone who knows how to deal with this?
#730 Old 29th Oct 2019 at 3:28 PM
From what I recall, there's a bug with the spells if the wizard already existed when this is installed.

I think at the time I killed my existing wizard and made the same one again (he was saved to the simbin) and then I reset his levels and stuff once he was added back and he functioned as he should. (all game spells plus grim's spell)
Any newly added wizard isn't affected by the bug even in kingdoms that existed prior to the spells install.
I'd imagine the same would be true for the monarch you gave magic to. A fresh monarch should be fine?
You could start a new kingdom to test that.

What do you mean, 'get a life'! I'm a gamer, I have many lives.
Test Subject
#731 Old 29th Oct 2019 at 6:37 PM
Wow Chickie, i had not expected a reply from you as youve been offline for a while (your one of the key modders i refered too, so this is a very nice surprise)

However i fear my situation is different
I had a fully clean instal and added the mods before even starting a kingdome so both the monarch (which btw has died already so he was no issue anymore (he was meant to die tbh, storywise))
But the wizard also is brand new as well
I could try your suggestion of killing and try again
I really hope i donr have to restart completely considering ive spend quiet the effort in setting up this story till the current point XD

But odd that in my case the newly made wizard is effected by said bug
#732 Old 30th Oct 2019 at 3:13 PM
I'm not sure I can help you beyond this point, I think I've forgotten most everything I previously knew.
As far as I recall I didn't do anything extra after I killed and remade my wizard.
Do the other parts of the core work with no problem?
Let me know if you get it to work or not
There's a small conversation about this on page 23 of this thread, posts 564 - 569 , and grim replies in post 573.
Selene had the same problem as you (new install).

What do you mean, 'get a life'! I'm a gamer, I have many lives.
Test Subject
#733 Old 31st Oct 2019 at 6:10 PM
Hello Chickie
Thanks for your help

Ive killed the wizard and made him anew, now he has access to deadly arrow and the others ^^
#734 Old 1st Nov 2019 at 10:50 AM
yw. I'm so glad you got it to work

What do you mean, 'get a life'! I'm a gamer, I have many lives.
Test Subject
#735 Old 7th Nov 2019 at 6:37 AM
Wow thanks for this. Just re installed Mideaval recently and became interested in mods and modding. So little around on this game. Thank you.
Test Subject
#736 Old 4th Dec 2019 at 2:08 AM
Nice mod, but... my game does not load at all after adding this mod. Don't know why.
Test Subject
#737 Old 7th Dec 2019 at 5:09 AM
This is an awesome mod. I added this mod due to wanting to use the debug mode and I can get into the debug mode without a problem, but no matter what I do..after I add even 1 thing from the debug mode, I can't get back into live mode or Kingdom mode. My game just hangs.....and hangs...So I must exit via task manager and therefore lose everything because I can't save. Very frustrating.

Has anyone have an idea of how to fix this? Thanks in advance..and thank you for your hard work!
Test Subject
#738 Old 8th Dec 2019 at 10:21 PM
I used to love this mod, but it hasn't been updated in a long time. After the Medieval update a few years back, this hasn't been updated, breaks the game, and the creator hasn't logged on since 2015. I think it's safe, and sad, to say this will never be updated unless someone else takes it on
Test Subject
#739 Old 12th Dec 2019 at 6:54 PM
Originally Posted by SwiftySuit
I used to love this mod, but it hasn't been updated in a long time. After the Medieval update a few years back, this hasn't been updated, breaks the game, and the creator hasn't logged on since 2015. I think it's safe, and sad, to say this will never be updated unless someone else takes it on

I am somewhat new here and with modding and I just got TSM recently so Im still learning. But after looking around some more, I have to agree with you. I have no clue how to mod, but maybe someone will be kind enough to take up the challenge and update this one or create a new mod for us to use. We can hope..
Thanks for responding..
Test Subject
#740 Old 24th Jan 2020 at 9:51 AM
@WickedEbony and @SwiftySuit, if you're still around to get this reply or if anyone else is wondering: this mod still works perfectly on the newest patch available through Origin. Please re-read the installation instructions for modding this game and make sure you have downloaded "version 2.0.13 beta" from the first post. I use it all the time and all the features work, nothing is glitched. That being said, I would love to see updates as well. :D

An easy thing to miss is: "This is a script mod so you must install d3dx9_31.dll in your The Sims Medieval\Game\Bin folder."
Lab Assistant
#741 Old 1st Feb 2020 at 2:03 AM
Just got medieval for win 10 recently followed the steps but I still get the same issue as I did with win 7: The menu/mod doesn't show up when I click options.
Test Subject
#742 Old 5th Feb 2020 at 12:27 AM
Posting from the far off year 2020. Just wanted to say a big thanks for this mod. I'm running the beta version and so far it's working great. Thanks!
Test Subject
#743 Old 24th Feb 2020 at 1:26 PM
Hey. is there link on source? Or maybe version, where all interactions for "sim debug interactions" are in one dialog menu? It is really great mod, but all interactions are in main dialog menu, I don't want always on/off this function Maybe it is a way how to group interactions in one menu?
Test Subject
#744 Old 26th Feb 2020 at 6:06 PM
@sparklisms I figured it out! I hadn't put my resource.cfg in my "mods" folder so it works now!! Modding this game is very tricky haha but thank you! Your comment gave me the motivation to work it out!
Lab Assistant
#745 Old 25th Sep 2020 at 7:38 AM
Same issue as Pollenfairy, it isn't finding the mods.
Tried with cfg in mods folder as well as in the game folder. Game is installed from disc but updated. The DLL is in the right place, but the menu won't show up in game. No idea what the issue is.
Lab Assistant
11th Nov 2020 at 7:54 AM
This message has been deleted by Paola3. Reason: I figured it out
Lab Assistant
#746 Old 12th Nov 2020 at 1:06 AM
The mod is "working" as in I see it in my game but its crashing my game everytime I access Furnishing mode. When I exit the mode, all Sims freeze, I am unable to click anything and then the game crashes to the desktop.
When I deleted the mod, I was able to use Furnishing mode without problems.
Page 30 of 30
Back to top