Replies: 135 (Who?), Viewed: 55187 times.
Page 6 of 6
Lab Assistant
Original Poster
#126 Old 12th Apr 2020 at 6:15 PM
There's now a test version of Graphics Rule Maker that enables the " disable the Texture Memory Estimate Adjustment" option that @1teslacourt brought to my attention from @Epi7. Using this should allow modern video cards to work on Windows 10 and for more CC. All without DXVK. Speaking of DXVK, users who want to continue using it could still use it for higher frame rates and using this option allows more CC with DXVK at a higher memory limit as well.

Users who want more CC with DXVK along with this option should also place in a dxvk.conf file like this one but modified to be "4096" and increase the forced texture memory in graphics rule maker.

I haven't had a chance to try the latest Graphics Rule Maker yet and it might be Nvidia-only at the moment. The GRM developer would like some feedback on that new functionality. The build and their feedback channel is posted on their Discord:
Lab Assistant
Original Poster
#127 Old 15th Apr 2020 at 1:38 AM
FYI @oOLampiOo ^
Lab Assistant
#128 Old 15th Apr 2020 at 5:51 PM
@crazysim> So if I understand it right, I can set texture memory in graphic rules to 4096 even though it's beyond DXVK's max VRAM emulation?
Lab Assistant
Original Poster
#129 Old 19th Apr 2020 at 4:28 PM
Originally Posted by Sechmet-The-Lazy-Cat
@crazysim> So if I understand it right, I can set texture memory in graphic rules to 4096 even though it's beyond DXVK's max VRAM emulation?

I haven't tried beyond yet. But the game does appear to start whereas it didn't earlier.
Lab Assistant
Original Poster
#130 Old 27th Apr 2020 at 12:19 AM
Posted another thread for the non-DXVK/test GRM approach that implements @Epi7's suggestion:
Test Subject
#131 Old 4th Oct 2020 at 1:07 PM
Can someone help me how to fix this problem?
Mad Poster
#132 Old 11th Nov 2020 at 10:58 PM Last edited by simmer22 : 11th Nov 2020 at 11:10 PM.
So I have this problem where the DXVK fix seems to cause crashes for no apparent reason - but without it I get the occasional bright item in CAS (not everything, just the odd hair/accessory/clothing item, and it's very random, seemingly having absolutely no links in regards to TXMTs or whether there's a bump map present or any of the kind).

Had one load with a dark CAS, but updated my drivers, and made sure the graphicRules files also got updated to the 2.0 version so the files were proper (the bright CAS items happened after that).

Outside of CAS the game seems to work better without the DXVK, loads a bit faster with the same amount of CC, no crashes (yet), no pink (yet), handles having shaders on... basically the only problem is the bright CAS items. And I'm pretty sure that's not a Microsoft issue, because I let Nvidia update the drivers.

It is a bit weird with those CAS items. It's almost like there's a setting somewhere that should be turned on or off, because why do some items show fine and others don't? (Doesn't look like it's the TXMTs, they're pretty much identical between files that seem fine and bright ones - maybe it's something in the GraphicRules that's turned on or off when it's not supposed to, but that's a bit over my head). Doing the DXVK thing just for some CAS items to show properly, and most likely not being able to use all the CC I kind of need for my story project seems a bit much. Wish there was another fix to this one...
Test Subject
#133 Old 15th Feb 2021 at 4:31 PM
Hi crazysim,

I'm running Windows 10 on a VM (Parallels), and I'm wondering if this will work? My graphics card is listed as "Intel Iris Plus Graphics 645 1536 MB", and it apparently does support Vulkan according to Intel, but vulkan_test.exe gave me a failure.

Do you know of anyone who's tried this fix on a Mac? For some background, these are the things I've tried so far (nothing has worked):
  • Using the 4GB Patch to directly patch the .exe.
  • Tweaking the graphics settings using Graphics Rules Maker. First I used the "Auto-detect" feature, then I played around with the settings myself.
  • "Repairing" the game using the Origin client (not even sure what this is supposed to do but thought it was worth a shot).
  • Entering the "boolProp UseShaders false" cheat. This removed the purple soup, but my walls are still flashing red and the graphics are still slow and horrible.
  • Editing Graphics Rules.sgr according to these tips.

Test Subject
#134 Old 27th Aug 2021 at 7:22 AM Last edited by emcinto0 : 27th Aug 2021 at 7:40 AM. Reason: Found way to upload log
Should I be concerned about this:

info: OpenVR: could not open registry key, status 2
warn: OpenVR: Failed to locate module

popping up in my TSBin/Sims2EP9RPC_d3d9.log?

I'm attaching everything because I'm not sure what you need. I'm running original flavor TS2 on Windows 10.
Download - please read all instructions before downloading any files!
File Type: 7z Troubleshooting_DXVK_ts2.7z (844.6 KB, 18 downloads)
Lab Assistant
#135 Old 30th Aug 2021 at 2:13 PM
Despite the installed DXVK, 4gb Patch, Graphics Rules Maker (Force texture memory 1024 mb), my BodyShop is still a pink soup. The game from time to time is flashing pink, but thanks to the "boolProp enableDriverMemoryManager true" code now much less often. But the BodyShop is actually not working. What can be done?
Windows 10
AMD Ryzen 7 PRO 4750G (with integrated videocard)
Mad Poster
#136 Old 30th Aug 2021 at 7:40 PM
^ Have you tried to copy/replace the GraphicsRules file from the Config folder to CSConfig in your M&G/SP9 (or latest EP) folder?
Bodyshop has its own GraphicsRules file in the CSConfig folder.

For the GRM, try ticking the "Disable texture memory estimate adjustment" - it used to be entirely gone from the GRM, but the new version added it back. My game was a pink soup like nobody's business before this, but adding that line (I did it manually, ticking the box does it for you) got rid of pretty much all the pink-flashing, at least the soupy kind that made my game absolutely unplayable.

"Enable driver's memory manager" is an option in the GRM.

Pink-flashing (just pink, really) in Bodyshop was kinda bizarre, because I've never had that before on my older computer. The "Disable texture memory..." line did the trick, along with the 4GB patch - haven't seen a scrap of pink in Bodyshop since.
Page 6 of 6
Back to top