Replies: 8 (Who?), Viewed: 1380 times.
Lab Assistant
Original Poster
#1 Old 24th Oct 2020 at 3:32 PM

This user has the following games installed:

Sims 2, University, Nightlife, Open for Business, Pets, Seasons, Bon Voyage, Free Time, Apartment Life
Default Error in Community Lot - Populator
Hi everyone!
I have a problem with owned community lots. Both when they are run by the owner and when sims visit them. Unowned lots are normal. I have tried the 50-50 method, and Midgethetree’s guide to find overrides in SimPE without luck. The only line in SimPE is located in the games object files. In a test hood with the same downloads folder owned business lots are normal. The hack conflict detector shows no conflicts that could explain this. This error seems to prevent sims from showing up on owned business lots, the only visitor is the reporter. Sims can be invited and will shop if I use the interaction to show goods but not otherwise. I can send a sim to the owned lots to shop but that playable will be the only customer.

Any help would be highly appreciated because this ruins the economy in my hood and I really don’t want to abandon it.

Forum Resident
#2 Old 26th Oct 2020 at 1:34 PM
I've never had this issue, but I'll try to see if I can help here...

The only thing I can think of that could be causing this is if you have a mod that alters playable sims coming to owned business lots. I know you said that you couldn't find overrides in SimPE, so that theory could be rendered null.

Another theory could be that the hood is facing issues, since you said that a test hood with the exact same downloads folder works fine. Based on the error log, which I'm not an expert on reading so don't quote me on it, the game is struggling to decide whether user created sims are allowed to spawn. More specifically, it's struggling to run the script that allows this to happen.

Why? I don't have a clue. I can only theorise here.

The Sims could have glitchy CC clothes, skins, or hairs, so the game can't spawn these sims and encounters an error. The Sims could have something else going on that requires a reset (Force Error --> Reset)...

Thinking about it, have you been to their home lots recently? If so, was there anything out of the ordinary?

Hopefully, someone more knowledgeable will come along, but I'm trying. These are the only things that spring to mind for me.

When a game is predictable, it's boring.
That goes for any medium that isn't life.
That's why The Sims 2 is my favourite sims game.
It has elements of unpredictability and everything feels more involved.
The Sims 4 is another story altogether...
#3 Old 27th Oct 2020 at 8:59 AM
By any chance do you have both the college tuition mod and the fetch water mod installed? I had someone report a problem like this when both were installed, and they removed fetch water and it fixed the problem. Never found out what the issue was, though. I've extracted that lua with SimPE and while I can generally figure out what it is doing I'm not even sure what instruction the error message relates to.
Lab Assistant
Original Poster
#4 Old 27th Oct 2020 at 6:31 PM
Thank you CrystalFlame360 and Kestrellyn!
I don't have the college tuition mod but removed the fetch water and visitors started to arrive so it does indeed seem to be the problem . (I don't know how i could have missed this in my 50-50). My test hood with the same downloads folder did not have the same issue so it seems that it may not show up immediately. Thank you so much! Hopefully I will find another mod in my downloads folder that conflicts because I really want to keep fetch water.
#5 Old 28th Oct 2020 at 12:31 AM
I think you'll find there's a fault in one of your sim's memories, at Frame 2: the current Object id: is not an item but a neighbour id so it wouldn't be the 'Global Sim - Temp Array' but Nid of 126 (0x007E), check that sim's memory for shopping tokens.
#6 Old 28th Oct 2020 at 1:42 AM
Since uninstalling fetch water seems to fix the issue and it doesn't appear in a clean test hood with fetch water installed, I wonder if it is caused by some object in inventory/memory/token created by that mod that is destroyed when the mod is removed. Probably someone should mention this to sunandmoon, since this is the second time I've seen this glitch related to fetch water.
#7 Old 28th Oct 2020 at 10:44 AM
I must have come across it before because I made a mod to use an op-code instead of the Lua script to prevent the problem a while ago. I have never used fetch water, no idea what it is. (800 Bytes), would require Apartment Life minimum.
Link Ninja
#8 Old 11th Aug 2022 at 7:33 AM
I know its been 21 months but I was having a heck of a time troubleshooting what was causing my CLP error and no sims were coming to my businesses and this patch by Chris did its magic and now my businesses can thrive again! It's only through google I found this little nugget of a fix mod. I'm definitely glad this is on my radar now in case others report the same issue and I can point them here.

Uh oh! My social bar is low - that's why I posted today.

Mad Poster
#9 Old Today at 11:57 AM
Just had this same problem myself and was panicking a little because it only happened in my uberhood, where about 140 businesses are owned by one single townie, and I thought I was gonna have to sell them all back or something. Anyway, I've never used fetch water, but I gave the patch a try anyway, and it worked, phew. Thanks, Chris!
Back to top