Hi there! You are currently browsing as a guest. Why not create an account? Then you get less ads, can thank creators, post feedback, keep a list of your favourites, and more!
Replies: 372 (Who?), Viewed: 187277 times.
Page 3 of 15
Field Researcher
#51 Old 8th Feb 2012 at 9:13 PM
Just noting that like Querin's screens, brady's show the same files red as I get in my error messages, even though my screen didn't show the file names clearly.
retired moderator
Original Poster
#52 Old 8th Feb 2012 at 9:23 PM
Thank you for the details, PoisonFrog and bradyseitz.

Baka- you mean on the left, where it says objectmanager.cs and so on?
Field Researcher
#53 Old 8th Feb 2012 at 9:45 PM
Originally Posted by simsample
Thank you for the details, PoisonFrog and bradyseitz.

Baka- you mean on the left, where it says objectmanager.cs and so on?

Yes. All those files are also red for my attempts, and when I looked at the tutorial screens are not red in those.
Lab Assistant
#54 Old 9th Feb 2012 at 3:58 AM Last edited by atavera : 11th Feb 2012 at 3:47 PM.
It looks like ILSpy is decompiling slightly different for a few of you. Until we know why, here is a temporary fix that you can try.

- Select CAW in ILSpy and Save Code again to a new folder
- Start TortoiseMerge
- Apply ilspy_difference.patch (from the attached zip file) as a unified diff to your project folder
- Now apply the original patch linked from the tutorial and continue normally

Edit(added link)
Lab Assistant
#55 Old 9th Feb 2012 at 4:04 AM Last edited by bradyseitz : 9th Feb 2012 at 5:43 AM. Reason: Results
I'll give it a shot and post my findings here when done.


I tried the temporary fix offered by Atavera. SUCCESS!! It worked! After using the difference patch, I no longer had the red files in TortoiseMerge when applying the original patch linked in the tutorial. The rest of the tutorial went through without a hitch. I got all the features in the Super CAW. Time to go play with my new toy.

Thanks to Simsample, Atavera, and all the others out there who have furthered the understanding of CAW. Now I can put in water planes and other effects much quicker!


Follow the creation of new worlds, lots and objects at my new blog, UrbanSims!
retired moderator
Original Poster
#56 Old 9th Feb 2012 at 2:11 PM
Hurrah! Well done bradyseitz!

Thanks for the fix, atavera!

Thank you to all who posted their information, and sent me files.
One horse disagreer of the Apocalypse
#57 Old 9th Feb 2012 at 3:10 PM
Yay!!! Glad it was fixable

"You can do refraction by raymarching through the depth buffer" (c. Reddeyfish 2017)
Test Subject
#58 Old 9th Feb 2012 at 5:45 PM
Atavera patch worked ! Thank you and Simsample so much.

And now to making new world...
Field Researcher
#59 Old 10th Feb 2012 at 1:34 AM
Well we have that patchfix, but just for curiosity's sake... I did get PC back today, with the Win7 Professional 64bit, and I still needed to use the patch fix Atavera put together, had same issues without it that my XP machine did.
Lab Assistant
#60 Old 10th Feb 2012 at 10:16 AM
WOW! This is probably one of the greatest news ever in Sims (3) world :-)

Thanks so much to you Atavera for finding and unlocking this extended CAW, Simsample for making great tutorials, and all the brave CAW users who tested this and helped fine tuning this.

just WOW.
Lab Assistant
#61 Old 11th Feb 2012 at 1:16 AM
Thanks bradyseitz, Querin for confirming it for me. And huge thanks to bakafox for being a guinea pig during the testing

I'm still not sure why some setups decompile caw slightly differently. It may help to know which versions of the .NET framework are installed on the ones that need the second patch. I cannot get the same decompile results on my machine, so I'm stumped. If someone that has this problem is willing to try the beta version of ILSpy to see if it does the same thing for them, that could be helpful.


I tried the beta and got the same results, but it is possible that they fixed something to make it more consistent.
Field Researcher
#62 Old 11th Feb 2012 at 4:13 PM
Stupid Question...
Well, maybe this a stupid question... but, is there anyway to install Microsoft Visual C# 2010 Express without downloading these?

I think I can't download it because I have slow Internet speed.

Me back after a long hiatus :)
retired moderator
Original Poster
#63 Old 11th Feb 2012 at 9:21 PM
I think those are required, so unless there is an option to deselect them you're out of luck. The download is only 143MB though; the 2.2GB is the disc space required.
Field Researcher
12th Feb 2012 at 8:16 AM Last edited by simsample : 13th Feb 2012 at 1:54 PM. Reason: Removed attachment
This message has been deleted by Black Zekrom. Reason: resolved
retired moderator
#64 Old 12th Feb 2012 at 9:16 AM
So I've installed this without a hitch, although CAW still eats all my prepopulated worlds. What I'm curious about is if we can do something similar with the EIG features that must surely be hiding there - in particular, I'm convinced there is a tool in there for adding families.

Huge props to all involved in this discovery.

CAW Wiki - A wiki for CAW users. Feel free to edit.

Test Subject
#65 Old 12th Feb 2012 at 5:01 PM Last edited by MoonsAreBlue : 12th Feb 2012 at 5:15 PM.
I'm using the new CAW right now, and so far I've had no problems and installation was a breeze. However, when you drag out the size of the lot, there is no 30x30 (as in lot size) in the lower right corner. It has moved to the lower left hand side and it says "The Lot Tool is ac..." and then "x:90.13 y:15.51 z:..." I'm assuming the first quotation says "The Lot Tool is active" and the second quotation is giving the lot coordinates and size, but since it cuts off with the "..." there is no way for me to tell the lot size as I am dragging it out. Does anyone have a clue how to extend the information? Or is this only happening to me? I'm finding it impossible to place the correct lot sizes that I need.

Thanks for your time! (This tool is great!)

Edit: Here's a picture of what I'm talking about.
Veteran Finn
retired moderator
#66 Old 12th Feb 2012 at 5:26 PM
Interesting - to me the lot size has always been on the right bottom corner.
Test Subject
#67 Old 12th Feb 2012 at 5:42 PM
That's the thing, though. There's absolutely no information on the right hand side, and the picture that I provided is the only lot information that this CAW seems to show.
Lab Assistant
#68 Old 12th Feb 2012 at 7:10 PM Last edited by simsample : 13th Feb 2012 at 2:50 PM.
Ah I hadn't noticed that. I updated the patch and this should be fixed now.

This is a full patch so you would need to start fresh with a new .csproj from ILSpy

Mod edit- Link removed, now added link to main tutorial. Thank you!
Test Subject
#69 Old 12th Feb 2012 at 8:54 PM
Works great! Thanks so much, atavera!
Veteran Finn
retired moderator
#70 Old 12th Feb 2012 at 9:02 PM
I have to admit I didn't open the super CAW before my last post. :/

The situation is the same for me too, so I suppose I need to repatch. I'm sorry if this has been answered already, but are there any spacial steps for deleting the older patched supercaw? Can it be just ripped off the install locations, or how?

And also, to add to my horror earlier about the game language changing in caw interface - the supercaw also makes it's own userfiles? I was looking for my worlds today, and could not find them, until I realized it had made English CAW folder under my documents. Opened my world from there and went to build.
If it doesn't do that for the people whose caw is already in english, but does it for all the non-english caw users, it might be worth to mention in the tut too
Trainee Moderator
staff: trainee moderator
#71 Old 12th Feb 2012 at 9:17 PM Last edited by simsample : 13th Feb 2012 at 2:42 PM.
Thanks a lot for the tutorial simsample.

I translated the tutorial into german in a short form:
Link removed by moderator- please see post #74
Lab Assistant
#72 Old 12th Feb 2012 at 9:19 PM
When re-patching, if you are inclined to use the same subfolder(for example I'm using C:\TS3\CAW\src where C:\TS3\CAW is my CAW installation folder) for your ILSpy extraction, it is probably good practise to delete everything in your supercaw folder before re-extracting and re-patching. The actual WorldBuilderCS.exe will get overwritten when you re-compile so you don't have to worry about deleting the olde one(but there is no harm in it).

As far as the language thing goes, I'm a bit confused. I sort of assumed if you decompiled your own CAW with another language, that would be preserved when you recompiled. The patch doesn't do any locale specific changes to force you into English mode, but it is possible ILSpy isn't taking that into account when exporting localised resources. I can look into this as I imagine it must be bad trying to use a familiar tool in an unfamiliar language. I can try changing my windoze language to achieve those outcomes for testing

Thanks all for testing and for the detailed reports of the issues.
retired moderator
Original Poster
#73 Old 13th Feb 2012 at 2:41 PM
Thank you all for your feedback and testing! I updated the tutorial with atavera's new patch, so please go there for the download link.

kiwi_tea- you saw the additional link in the first post to the packaging routines?

armiel- I added a note about the English folders to the tutorial too.

Jawusa- Please don't share the executable! Patching to fix your own exe is easy enough. The reason that we chose to share a patch rather than to share a modified executable is one of legality- we cannot share EA executables as that amounts to piracy. Please remove that tutorial and instead translate my tutorial directly if you wish to have a German version. Please also follow my instructions to Nilixis here:
I would prefer that you link to our files rather than to re-host them, as this allows us to update the patch as needed (as has already been necessary). Thank you, I would be very glad to see a German version, but we must be careful not to violate EA copyright.

atavera- Thanks for all your work on this, as you can see there are many people here who are very thankful for this!
Test Subject
#74 Old 13th Feb 2012 at 4:01 PM
Atavera, I've tested Ilspy Master 2.0 and it gave the same error as before.
Whatever is causing bugs in decompilation seems to be persistant in my OS.

On other hand, your ilspy difference patch and supercaw patch works great.
Trainee Moderator
staff: trainee moderator
#75 Old 13th Feb 2012 at 8:03 PM
I'm so sorry simsample,
I updated the tutorial and changed a lot.
The updated tutorial is not short, its long.

Page 3 of 15
Back to top