Replies: 99 (Who?), Viewed: 205223 times.
Page 4 of 4
Test Subject
#76 Old 26th Jul 2020 at 5:00 PM
Quote:
Originally Posted by malysz9999
I have problem. After formatting my hard drive and installing everything again I don't have any MPEG Layer-3 formats

Did you ever manage to find a solution? I have the same issue with no options in MPEG Layer-3
I also have an issue where the GUI will not create the .dat when adding the command line. Going ahead without it leads to a video that isn't synced with the audio and appears to be running in slow motion.
It wasn't a re-format that resulted in the issue in my case.

There doesn't seem to be much info elsewhere on this topic.

Anyone here who might know something, seems to be avoiding these particular questions.
Advertisement
Test Subject
#77 Old 19th Oct 2020 at 10:52 AM
Does anybody know of any more UPDATED instructions the the ones given by the OP? They are TWO YEARS outdated
Test Subject
#78 Old 12th Nov 2020 at 8:44 AM
Thank you so much for sharing all of this information.
Test Subject
#79 Old 14th Jan 2021 at 11:33 PM
Anyone who's having the issue where VP60 Simple Profile doesn't appear in the video compression, I found a way to fix it!
Go to "C:\Program Files (x86)\Origin Games\The Sims 4\__Installer\vp6" and copy "vp6vfw.dll"
then go to "C:\Windows\System32" and paste the .dll file. This will require admin powers.
Then restart VirtualDub and the VP60 Simple Profile should appear!
Test Subject
#80 Old 16th Feb 2021 at 4:50 AM
Custom Videos show as black screens
I was able to get one video working, but every video I have tried since has shown in game as a black screen. I'm unsure of what I'm doing wrong, I have followed all the steps to the letter. Is anyone familiar with this issue and/or know how to fix it?

Thanks
Test Subject
#81 Old 27th Mar 2021 at 6:11 AM
Quote:
Originally Posted by SammyDowdz
I was able to get one video working, but every video I have tried since has shown in game as a black screen. I'm unsure of what I'm doing wrong, I have followed all the steps to the letter. Is anyone familiar with this issue and/or know how to fix it?

Thanks


Hi there! Sorry to bug you about this more than a month later, but I may have had the same issue. Do you happen to have Laptop Mode on? My TV channel video was not quite black, but was so dim, I could hardly see it. When I turned off Laptop Mode and reloaded the game, my video was then as bright as it should've been. Afterwards, I tried setting just about everything else as low as I could, even Lighting, but the TV's screen was bright unless Laptop Mode was on.
Test Subject
#82 Old 28th Mar 2021 at 3:30 PM
Hi, is generic stream creator still avaliable to download? I can't find it anywhere and the download link here doesn't work. At least not for me.
Test Subject
#83 Old 3rd May 2021 at 5:50 PM
Hi Guys

I have a question, someone here get this mod to work? I really want to create a new channel for something pretty and very interesting ( ͡° ͜ʖ ͡°).

I create my own channel from this tutorial, the only thing that i had some question was about rename instances Tuning and the same time SimDatas Video Playlists. Is that possible? Thanks anyway for all.
Test Subject
#84 Old 14th Jun 2021 at 1:27 PM
Quote:
Originally Posted by malysz9999
I have problem. After formatting my hard drive and installing everything again I don't have any MPEG Layer-3 formats

did you fix your problem i'm also facing this and im getting pissed...
Be like the 22nd elephant with heated value in space, bark!
retired moderator
#85 Old 14th Jun 2021 at 2:02 PM
You probably all need to download some MPEG layer 3 codecs- if you do an internet search you will find a number of sites that provide these.

I will choose a path that's clear- I will choose free will
-RUSH- -RADIO- -EON- -ARCHIVES-
Simpeople and Me Archive- -11Dots Archive- My Sims World Archive
Test Subject
#86 Old 15th Jun 2021 at 7:53 AM
Quote:
Originally Posted by simsample
You probably all need to download some MPEG layer 3 codecs- if you do an internet search you will find a number of sites that provide these.

ive downloaded all the codecs i know and still it won't show up... can you give me the link for yours? any fix at all
Test Subject
#87 Old 15th Jun 2021 at 8:00 AM
Quote:
Originally Posted by simsample
You probably all need to download some MPEG layer 3 codecs- if you do an internet search you will find a number of sites that provide these.

also it the option of 320 48000 only shows on AC3 not MPEG3 and when i use those this error pops out which is very irritating and confusing because all the other help desk i searched are outdated for like 8 years
Screenshots
Test Subject
#88 Old 23rd Jun 2021 at 7:29 PM
My videos are played frame by frame (almost slowly)
What is the problem?
Test Subject
#89 Old 21st Jul 2021 at 7:11 PM Last edited by SammyDowdz : 22nd Jul 2021 at 4:50 AM.
Default Issues with skewed output from VDub export
Hey guys,

I've been having an issue where exporting my file through Vdub will distort the video. The image comes out low quality, black and white, and slanted. I can't seem to find a solution online and I'm wondering if anyone here has had a similar issue and knows how to fix it.

*EDIT

fixed this issue, seemed to be an issue with using MPEG-4 formats in VDub. I exported my file from premier as an .avi and then into VDub and it works fine now. Just in case anybody else is having this issue.
Test Subject
DELETED POST
22nd Jul 2021 at 4:56 AM
This message has been deleted by SammyDowdz.
Test Subject
#90 Old 22nd Jul 2021 at 5:15 AM
Quote:
Originally Posted by GaryUmbreonWolf
Hi there! Sorry to bug you about this more than a month later, but I may have had the same issue. Do you happen to have Laptop Mode on? My TV channel video was not quite black, but was so dim, I could hardly see it. When I turned off Laptop Mode and reloaded the game, my video was then as bright as it should've been. Afterwards, I tried setting just about everything else as low as I could, even Lighting, but the TV's screen was bright unless Laptop Mode was on.


heya, thanks for the reply. I haven't been playing with laptop mode on and my other channels all display fine, it's just the channel with the new video that's not playing correctly. The video isn't just dim it's entirely black. I've checked the final video before saving it into a package and it plays with no issues, so the issue must be occurring when saving the video into a package file with the S4 package editor.

I've already successfully replaced one channel with a custom video and it plays in game with no issues, quite puzzled as to why it isn't working with this new video.
Any help would be majorly appreciated.
Test Subject
#91 Old 8th Feb 2022 at 12:17 PM
Default VP6 builder
Quote:
Originally Posted by huguette123
Hi, is generic stream creator still avaliable to download? I can't find it anywhere and the download link here doesn't work. At least not for me.


Bit late but here are the original files by Siberian GRemlin
Download - please read all instructions before downloading any files!
File Type: rar VP6_Builder.rar (193.4 KB, 55 downloads)
File Type: rar SoundExchange30101_GUI.rar (183.6 KB, 0 downloads)
File Type: rar SoundExchange30101.rar (214.1 KB, 45 downloads)
Test Subject
#92 Old 14th Mar 2022 at 12:00 PM
Can anyone provide updated links to the generic stream creator file?
I can't download it anymore as the links are broken.
Test Subject
#93 Old 14th Mar 2022 at 12:01 PM
Quote:
Originally Posted by BrDarkness
Bit late but here are the original files by Siberian GRemlin

Thanks for your links!
The first and last link worked, the second one doesn't work though.
I think that's the file which is the generic stream creator UI command file that I'm trying to download from the front page but can't because the links are broken.
Anyway I'm trying to google other places I can try find it with no luck atm, but thanks for the other links you provided!
Test Subject
#94 Old 20th Mar 2022 at 11:40 PM
Quote:
Originally Posted by steeerben
ive downloaded all the codecs i know and still it won't show up... can you give me the link for yours? any fix at all

Same here. Having this problem too and I can't get past this step despite my best efforts.
Test Subject
#95 Old 5th Apr 2022 at 4:16 PM
https://modthesims.info/showthread....820#post3084820 is the TS3 post with the files in a rar archive.
Test Subject
#96 Old 8th Apr 2022 at 9:44 PM
As a few users seem to have problems with the old document I'll post my small guide here. It's only about encoding and does not require the installation of additional MP3 or other codecs except VP6.
It's heavily based on the work of Simser der Deutschen and may others.

Required skills
bash / cmd to automate the process as much as possible. Most commands can be added to a single script or batch file, while 'VP6Converter' and Sims4Studio require manual interaction.
To use this guide you may either install 'GIT' and start the 'Git Bash' on Windows, or use a unix based system like MacOS / Ubuntu with 'wine'.
Of course you can adjust the commands for the Windows 'cmd'. If you use it:
  • skip everything before the first './'.
  • replace 'export ...' with 'set ...', 'rm -f ...' with 'del ...', ${...]' with '%...%', ...
  • watch out for
  • Better use the 'Git Bash'

Required tools
'Sims4Studio' to add the video to a package from https://sims4studio.com/
'ffmpeg' to convert, split and cut the video from https://ffmpeg.org/
'vdub' to encode the video as a VP6 stream from https://virtualdub.org/
'vp6.vdscript' for 'vdub'
'sx' to encode the audio stream as 'ADPCM EA R3'
'vp6_vfw_codec' to install VP6 codecs
'VP6Converter008' or 'VP6Converter005' to join both streams in an 'EA' AVI container. Both versions have bugs while the latest is much faster if it works.
'GUI' and 'VP6Converter007' are not required but included in the zip.
'Git Bash' highly recommended for Windows https://git-scm.com/download/win

Preparation
Download the required files and install Sims4Studio, ffmpeg, VirtualDub and the VP6 codecs.
I extracted the zip archive to a folder 'video-tools' and assume that you do the same.

Remove all temporary files (starting with '_') from a previous run.
Code:
cd 'video-tools'
rm -f _ffmpeg.mp4 _vp6.vp6 _vp6.mp4 _rawvideo.mp4 _vp6.avi _pcm_s16le.wav _adpcm_ea_r3.dat  #   cmd: 'del ...'- 1st time there will be no files!


Preparing the video
You may use your favorite video editor to create the '_ffmpeg.mp4' file. Just make sure that the size and fps are set correctly.
I'll post the command line option which is quite easy if the video is simply resized.
Code:
export file="video.mp4"  # ffmpeg can read many formats
export ss="00:00:00.000"  # start time, in case we want to skip a few seconds or µs
export t="00:00:30.000"  # duration to keep the video short, eg. 30s
export scale="512:288"  # should be '512:288' or '128:144' for TV. Supported sizes: '32×w:16×h' with random w, h
export fps=15  # 15 fps work fine

# Refer to the ffmpeg manual to crop or letterbox a video. With the code below only the start time and size is adjusted. 
ffmpeg -i "${file}" -ss ${ss} -t ${t} -codec copy "_ffmpeg.mp4"  #   cmd: 3x %...%


From here on we need a file named '_ffmpeg.mp4' to work with it.
'ffmpeg' will create uncompressed streams. The other tools can read them without the need for a special codec.. We'll use 'sx' to encode the audio stream and 'vdub' to encode the video stream afterwards.

Code:
ffmpeg -y -i "_ffmpeg.mp4" -vf "[in]scale=${scale}[mid]; [mid]fps=${fps}[out]" -vcodec rawvideo -pix_fmt rgb32 -ar 48000 -ac 2 -acodec pcm_s16le -map 0:v "_rawvideo.avi" -map 0:a "_pcm_s16le.wav"  #   cmd: 2x %...%
# wine ./sx.exe _pcm_s16le.wav -sndstream -eaxa_blk -fps${fps} -cbr384000 -loops-1 -loope-1 -=_adpcm_ea_r3.dat  # Defaults: 15 fps, 384k CBR, no loops - so no reason to specify these.
wine ./sx.exe _pcm_s16le.wav -sndstream -fps${fps} -noprogress -=_adpcm_ea_r3.dat  # _pcm_s16le.wav >_adpcm_ea_r3.dat  #   cmd: %...%
nice -n 20 wine ./vdub.exe /s "vp6.vdscript"  # _rawvideo.avi >_vp6.avi


In case you wonder about the missing VBR mp3 section:
We will not feed any audio stream to VirtualDub or create one. VirtualDub encodes only the video to VP6 and it makes absolutely no sense to care about audio.
With 'sx' we rely on the default parameters to encode the audio. It doesn't improve a thing to specify them in a complicated way in 'GUI.exe'. With '-noprogress' no progress bar will be displayed.


Create an 'ea' container with the two streams
We simply join the two files into one container
This tool seems to have no command line options to specify the input files. On Windows the video file may be specified as the 1st parameter.
Load '_vp6.avi' and '_adpcm_ea_r3.dat' and click on 'GO'.
If reading the audio stream fails use 'VP6Converter005'
Code:
wine ./VP6Converter008.exe  #  _vp6.avi + _adpcm_ea_r3.dat >_vp6.vp6
ffmpeg -y -i _vp6.vp6 _vp6.mp4

There is absolutely no need to change the filename. You may do this anyway and rename it to 'tv-sport.avi.binary' or something like this. I assume that you keep the file name as-is.
The 'ffmpeg' command encoded the result to mp4 so we can view the result with the normal video player and don't need 10 year old codecs for it. Depending on the ffmpeg version audio may be missing.

Testing
I'm not aware of a reliable way to detect whether the video will crash the game or not.
The number of audio and video frames should, but doesn't have to be identical.

A) If you already have 'author-tv-sport.pacakge' open the file and skip option 'B)'.
B) Open S4S, create a new empty package ''The Sims 4/Mods/author-tv-sport.pacakge' (or something like this) and use the Game File Cruiser to locate '0x83AA458A9FF99646' and add it to the current package. Close the Game File Cruiser window.
Click 'Import', select 'All Filetypes (*.*)' and import '_vp6.vp6'. Save the package.
Start TS4 and play the video.

Game Crash
If the game crashes at the end of the video instead of looping decrease the number of frames of a random or both streams. VP6Converter may remove extra frames from both files while encoding.

Audio
Code:
a=$( ffprobe -v error -select_streams a:0 -count_packets -show_entries stream=nb_read_packets -of csv=p=0 "_f_pcm_s16le.wav" ) && printf "Audio frames: %s\n" "${a}"
aa=$(( $a -1 )) && printf "Audio: %s\n" "${a}"
mv "_pcm_s16le.wav" "_pcm_s16le.wav.$a"
ffmpeg -i _pcm_s16le.wav.$a -vn -acodec copy -frames:a ${a} _pcm_s16le.wav
#   cmd: ffprobe -v error -select_streams a:0 -count_packets -show_entries stream=nb_read_packets -of csv=p=0 "_f_pcm_s16le.wav"
#   cmd: rename the file manually and specify a smaller number of frames for ffmpeg.


Video
Code:
v=$( ffprobe -v error -select_streams v:0 -count_packets -show_entries stream=nb_read_packets -of csv=p=0 "_rawvideo.avi"  ) && printf "Video frames: %s\n" "${a}"
vv=$(( $v -1 ))
mv "_rawvideo.avi" "_rawvideo.avi.$v"
ffmpeg -i "_rawvideo.avi.$v" -an -vcodec copy -frames:v ${a} "_rawvideo.avi"
#   cmd: see above


Now re-encode audio with 'sx' and/or video with 'vdub' if modified and join again with 'VP6Converter'.
Rinse and repeat until it works in-game. Sometimes many iterations are needed. A few times 'VP6Converter008' will not be able to read the audio stream.

Have fun!
Download - please read all instructions before downloading any files!
File Type: zip video-tools.zip (2.59 MB, 34 downloads)
Test Subject
#97 Old 26th Apr 2022 at 1:11 PM
Quote:
Originally Posted by o19
Game Crash
If the game crashes at the end of the video instead of looping decrease the number of frames of a random or both streams. VP6Converter may remove extra frames from both files while encoding.

Audio
Code:
a=$( ffprobe -v error -select_streams a:0 -count_packets -show_entries stream=nb_read_packets -of csv=p=0 "_f_pcm_s16le.wav" ) && printf "Audio frames: %s\n" "${a}"
aa=$(( $a -1 )) && printf "Audio: %s\n" "${a}"
mv "_pcm_s16le.wav" "_pcm_s16le.wav.$a"
ffmpeg -i _pcm_s16le.wav.$a -vn -acodec copy -frames:a ${a} _pcm_s16le.wav
#   cmd: ffprobe -v error -select_streams a:0 -count_packets -show_entries stream=nb_read_packets -of csv=p=0 "_f_pcm_s16le.wav"
#   cmd: rename the file manually and specify a smaller number of frames for ffmpeg.


Video
Code:
v=$( ffprobe -v error -select_streams v:0 -count_packets -show_entries stream=nb_read_packets -of csv=p=0 "_rawvideo.avi"  ) && printf "Video frames: %s\n" "${a}"
vv=$(( $v -1 ))
mv "_rawvideo.avi" "_rawvideo.avi.$v"
ffmpeg -i "_rawvideo.avi.$v" -an -vcodec copy -frames:v ${a} "_rawvideo.avi"
#   cmd: see above


Now re-encode audio with 'sx' and/or video with 'vdub' if modified and join again with 'VP6Converter'.
Rinse and repeat until it works in-game. Sometimes many iterations are needed. A few times 'VP6Converter008' will not be able to read the audio stream.

Have fun!


I have been trying your solution to fix the game crash but it doesn't seem to be working. I have rinsed and repeated the instructions many times but it does not seem to help.
Test Subject
#98 Old 29th Jul 2022 at 3:17 PM
Default Has anyone done this recently
Quote:
Originally Posted by Naminator999
I have been trying your solution to fix the game crash but it doesn't seem to be working. I have rinsed and repeated the instructions many times but it does not seem to help.



I'm not to modding and it seems this is the only way to add a custom video into sims 4. Please if anyone can send me a new tutorial on how to do this on a mac that would be appreciated. I've read the whole thread and I'm very confused.
Test Subject
#99 Old 10th Aug 2022 at 8:56 AM
Default I got it
Quote:
Originally Posted by seelea92
I'm not to modding and it seems this is the only way to add a custom video into sims 4. Please if anyone can send me a new tutorial on how to do this on a mac that would be appreciated. I've read the whole thread and I'm very confused.


Hi i recently found this tutorial https://youtu.be/gDsEydLKc1s

And it work for me, it's pretty simple and easy also you can download there all the programs needed. The only problem that i had is that the GUI never gave me the
.dat file, so the video has no audio but i have no problem with it.
Test Subject
#100 Old 28th Sep 2022 at 9:51 PM
Quote:
Originally Posted by Twyla
Hi i recently found this tutorial https://youtu.be/gDsEydLKc1s

And it work for me, it's pretty simple and easy also you can download there all the programs needed. The only problem that i had is that the GUI never gave me the
.dat file, so the video has no audio but i have no problem with it.


Was having the same issue with GUI/sx not creating the .dat file. I moved the .wav, GUI.exe, and sx.exe to a new folder all by themselves, ran as administrator and it worked fine.
Page 4 of 4
Back to top