Replies: 681 (Who?), Viewed: 362928 times.
Page 3 of 28
Test Subject
#51 Old 5th Nov 2006 at 2:27 PM
Operating system Windows XP Pro + all security updates
Computer specs AMD Athlon FX60 64bit processor, 2GB RAM, ATI x1900xtx graphics card
Games Sims 2 CD version, University CD, Nightlife CD, Family Fun Stuff CD, Holiday Pack 05 EA Link Download, Open for Business CD, Glamour Life EA Link Download, and Pets DVD.
Details of Neighbourhood loss Playing Pleasantview with only 1 custom family after install of all the above games. Pleasantview lost after system crash with auto restart during save when attempting to quit game. Strangetown and Veronaville still alive and well, neither touched since game install.
The ONLY hack installed at time of crash was InSIMinator OBJ edition. I was closing the game down at the time in order to get more downloads for use in the game.
Neighbourhood File details All files still accounted for in each folder for each neighbourhood.
Sim PE Investigation: Don't have Sim PE, not a fan of it as it is too difficult to navigate.
What changed on your system immediately before the corruption: The only strange occurance to happen is that after installing the Pets expansion first time around, the game kept crashing and auto restarting my computer either during load of the neighbourhood or straight after the EA logo at the startup. This was only fixed after removing the entirity of The Sims 2 and all expansions and reinstalling them.
Any other relevant information: I'm noticing a lot of people have the same problem, I have an idea of my own to try and will let you know how I get on. This is the first time this problem has happened to me and I think it relevant to say that it has only happened after the install of Pets. Before that the game worked perfectly.

Could you also try this:
Go to My Documents/ EA Games/ The Sims2/ Neighbourhoods and cut and paste the neighbourhoodManager.package file to your desktop. Now go to Program files/ EA Games/ The Sims2/ TS Data/ Res/ User Data/ Neighbourhoods and copy the neighbourhoodmanager.package file- paste it into your Documents folder where your old neighbourhoodmanager file was. Does that make any difference?

Tried and did not work. Absolutely no difference what-so-ever.
Just east of Lyra, northwest of Pegasus
retired moderator
Original Poster
#52 Old 6th Nov 2006 at 11:41 AM
Max Outrider, if your computer restarted this usually indicates hardware fault- perhaps overheating. What most likely happened in your case was that the crash corrupted the neighbourhood files.
Test Subject
#53 Old 7th Nov 2006 at 8:48 PM
First, sorry if my english isn't good because I'm French.

Operating system Windows XP Home

Games Nightlife - University - Open for Business

Details of Neighbourhood loss I lost Strangetown after I try to create a new Neighborhood with the Strangetown's "characters" file, but Pleasantview and Veronaville are okay.

Sim PE Investigation I can see and modify Strangetown in SimPE.

What changed on your system immediately before the corruption Nothing, I think.

Thanks for reply(s)
Test Subject
#54 Old 7th Nov 2006 at 10:36 PM Last edited by RedKatt : 8th Nov 2006 at 12:08 AM.
Operating system: Win Xp Home
HomeComputer specs: Amd Athlon 64 processor 3800+, 2.41GHz, 1GB RAM, NVIDIA GeForce 7600 GS
Games: Sims 2 CD, Sims 2 University CD, Sims 2 Nightlife CD, Nightlife Patch
Details of Neighbourhood loss: My custom neighbourhood is the only one I ever touch, N004, now my problem seems to differ from other peoples, I am perfectly able to play the original neighbourhoods but my custom neighbourhood has vanished completely ingame and this actually occurred while I was playing it, I am also unable to create -any- new custom neighbourhoods, the option for this is greyed out.

Two things happened before I lost my neighbourhood and ability to create custom neighbourhoods, firstly I had just added some new custom stuff all clothes/hair, secondly the space on my C drive where the sims saved games are was running low on space.

I was in game (after having put my new downloads in the game) playing a character in my custom neighbourhood, he was taking a taxi to downtown when downtown loaded it loaded in build mode, I clicked on the icon to return me to my custom neighbourhood, it loaded the splash screen with the neighbourhoods name but it returned to downtown everytime, puzzled I returned to the main menu only to find my custom neighbourhood had completely vanished.

I since backed up my neighbourhood that was saved on my C drive (the actual game is installed in another drive) and reinstalled everything, I moved my custom neighbourhood back into my newly installed folders and had exactly the same problem, no custom neighbourhood, absolutely no ability to create a custom neighbourhood.

As you can guess I'm pretty damn annoyed, not only can I not touch the neighbourhood I play I can't even create a new one to start from scratch from. If I ran out of space on drive C while in play I can understand corrupting my save file, however what I can't get my head around is the choice of making a new custom neighbourhood being greyed out.

I have never installed any hacks, and I removed all custom content before I reinstalled and have not put it back.

Any input would be greatly appreciated.

Update: I thought you might find this interesting. I found a backup of this neighbourhood albeit slightly old. Once I moved that into my saved games folder I found that I was able to play it. However because it was old I wondered if there was any way to drag the character files into the character folder of the backup game, I also copied my saved crashed game lots over my old backup lots, I booted up the game, I saw the neighbourhood with added lots and I loaded a house, in this house I found people who had been at the university neighbourhood now back in their original homes acting like the age they were of the old backup game but in their young adult skins with the same hair/makeup I had left them with in my crashed game. I decided to copy the downtown/university packages of my saved crashed game over my backup game ones, when I came to load the game again my neighbourhood had once more disapeared. So it seems for me the fault is in one of the university/downtown packages.

Final Update: I replaced the backup game university package files with the crashed games one, the neighbourhood still loaded, however it was still loading the backup neighbourhoods houses. I copied the crashed game neighbourhood.packagae file over the backup one, booted up the game, no more neighbourhood, I can ony assume then that my neighbourhood.package was corrupt, I doubt theres anything I can do but admit defeat and play from my backup. I assume it corrupted when it tried to save and ran out of space on drive C. My only advice is backup your game regularily and don't let your stupid brother partition your hardrive with a mere 10GB drive C partition :p
Lab Assistant
#55 Old 8th Nov 2006 at 3:36 AM
simsample, you say its a savegame corruption, i was not saving when the game crashed and neighbourhood disappeared, i was having a party and playing normally. what was the wrong thing i did? maybe i did not save the game after i deleted some lots (i can't remember if i saved it or not before it crashed) maybe it did not save that i deleted them, so a corruption happened!!

does uninstalling and reinstalling the game do anything to solve the problem?
Test Subject
#56 Old 8th Nov 2006 at 9:02 AM
Originally Posted by RedKatt
"he was taking a taxi to downtown when downtown loaded it loaded in build mode"

Ah yes, somthing i had forgotten was that the same thing happened to me. After taking a taxi downtown, i entered the lot in build mode. I had the ability to move and replace items even though the lot wasn't owned by my sim, but any money used came out of my sim's bank.

Similarly, i couldn't use sim mode again, as it was grey'ed out, meaning my sim had left the house without saving, and i had no option but to return to the neighborhood.

That only happened after a few crashes. It appears these seem to be starting all the problems.
Just east of Lyra, northwest of Pegasus
retired moderator
Original Poster
#57 Old 8th Nov 2006 at 1:49 PM
Originally Posted by love247_jo
simsample, you say its a savegame corruption, i was not saving when the game crashed and neighbourhood disappeared, i was having a party and playing normally. what was the wrong thing i did? maybe i did not save the game after i deleted some lots (i can't remember if i saved it or not before it crashed) maybe it did not save that i deleted them, so a corruption happened!!

does uninstalling and reinstalling the game do anything to solve the problem?

When the game is in use the savegame files are being read. It is possible that when the game crashed the corruption occurred- the game does not necessarily need to be writing at the time of crash for a corruption to occur. The sims isn't like other games where the savegame is a single file; in fact there are many files that get altered when saving. The neighbourhood files (which contain memories, so when your sim meets Mort Goth then Mort's memory is altered too), neighbourhood decorations, the lot details, sub-neighbourhood details etc. There are a lot of files that the game needs to read just to be able to have a party! Each of the sims invited has motives, memories, relationships that are being maintained.
Test Subject
#58 Old 9th Nov 2006 at 12:53 PM
My problem is I have two custom neighbourhoods, but only one appears when I load the game.

Operating system: Win XP Pro

Computer specs: AMD Athlon XP 3200+, 2.19 Ghz processor, 1 Gb RAM, NVIDIA GeForce FX 5700 Ultra

Games: Sims 2 PC, University, Nightlight, Open for Business, Family Fun Stuff

Details of Neighbourhood loss I lost a custom neighbourhood. I deleted the the neighbourhoods that came with the game about six months ago. The custom hood that was lost is the one I've been playing most recently. I haven't removed the downloads folder recently, either.

Hacks: Lizzlove's Waterbed of Love, "Swinger's Bed" global hack, Swinger's Hot Tub, No Privacy mod, Modest teens and hottubs fix, no-jealousy-at-all behaviour package, Inteenimater, Merola's Multipainting and Mind Control Mirror, Carrigon's College Helping hand (not sure if that is the correct name) and Large Abduction Crystal, DJS Sims Bob the Reward Gnome, Automatic NPC Scheduler Aspiration Reward and Home Shopping PC

Neighbourhood File details The 'hood file shows up in Documents/ EA Games/ The Sims2/ Neighbourhoods, with all the relevant files

Sim PE Investigation: The 'hood shows up in Sim PE, but with the file path Documents/ EA Games/ The Sims2/ Neighbourhoods/etc, etc instead of the file name. when I doubleclick on the file to open it, Sim PE gives me an error message, and can't open the 'hood. My other hood appears as normal in SimPE.

What changed on your system immediately before the corruption: I deleted about three other custom 'hoods (using the in-game deletion), left one and created a new one. I also created a custom university 'hood, something i've never done before. I then played the new 'hood and then shut down the machine. this morning when I started up the game only the I created yesterday is showing up.

Any other relevant information: In the last couple of days, I've noticed that while in the university lot of my lost hood, the game continues to run while in build and buy mode (ie the sims still move around and do stuff) I've also had total loss of sound and a really weird camera angle that I didn't set.I fixed the camera angle, but the sound seemed to randomly come and go.

Could you also try this:
Go to My Documents/ EA Games/ The Sims2/ Neighbourhoods and cut and paste the neighbourhoodManager.package file to your desktop. Now go to Program files/ EA Games/ The Sims2/ TS Data/ Res/ User Data/ Neighbourhoods and copy the neighbourhoodmanager.package file- paste it into your Documents folder where your old neighbourhoodmanager file was. Does that make any difference?

I tried it, but it didn't make any difference


~ I'm the sanest person I know ~

My YouTube Channel
Field Researcher
#59 Old 9th Nov 2006 at 10:32 PM
A similar thing has happened to me before.

here is my story, I played on the neighborhood veronaville which had all my sims in it, After that my friend came around and asked if she could make a family and a house on the pleasantview neighborhood. She made the sims, the house and then moved the sims in, saved it and then came off to let me have a go at playing around with my sims. Then the next day I let my friend go back on the game to carry on with her home, something wasnt right, there was no music and the house that my friend made was for sale, yup it just deleted the family that she had put in there! I checked to see if the same had happened with the other neighbourhoods and the same had happened with strangetown! the only neighborhood not effected was veronaville (which was fine by me since all my families were there, but it isnt fair on my friend is it?) I dont know why it did this but In the end I deleted Pleasantview and strangetown and let my friend build a home in veronaville! Yes everythings fine now apart from I only have one neighborhood, But why did it happen? it should not do this!

Also a few days after this incident the game wasnt playing music and the TV was not working, the screen just had a big red cross through it when my sims turned it on! however when I installed Nightlife it repaired this for me, how nice of it!

But a game is a game and it isnt here to stress us out by automatically deleting some of my friends creations!

My Computer is a Mac OSX version 10.4.8
It currently has 512Mb of memory
the computer specs are: 2.1 GHz PowerPC G5

This is above the minimum requirements i think!

The games I own are Sims base game and Sims nightlife.
Test Subject
#60 Old 10th Nov 2006 at 6:05 PM
Default No Veronaville!
Operating system \ Win XP Home
Computer specs -?
Games Sims 2,Pets,University,Open For Business,Glamour Life,Nightlife
Details of Neighbourhood loss- I lost Veronaville,the others are ok.

Neighbourhood File details If you go to Documents/ EA Games/ The Sims2/ Neighbourhoods are the neighbourhood files still there? Pleasant View,and Strangetown are. Downtown,Colleges,Bluewater Village are all there..but no veronaville.

What changed on your system immediately before the corruption: I had downloaded some hair from you,and something appeared about a neighborhood. Not knowing what it was, I pressed yes and lost veronaville.

Any other relevant information: I wasn't playing the game when it happened.

Could you also try this:
Go to My Documents/ EA Games/ The Sims2/ Neighbourhoods and cut and paste the neighbourhoodManager.package file to your desktop. Now go to Program files/ EA Games/ The Sims2/ TS Data/ Res/ User Data/ Neighbourhoods and copy the neighbourhoodmanager.package file- paste it into your Documents folder where your old neighbourhoodmanager file was. Does that make any difference?Nope
Can you please help me? I was mostly playing Veronaville!
Test Subject
#61 Old 17th Nov 2006 at 12:56 AM
Default Strangetown Saga
System Details:
Pentium(R) 4 CPU 3.20Ghz,
3.19 Ghz, 1.00GB of RAM
Windows XP Home Edition '02
Alienware Computer

Neighborhood Details

I made a really cool house in Strangetown and then saved the game. The computer then accidentally got turned off without exiting the game. When i restarted the game everything was ok so i finished my house. Then the next day the neighborhood is gone. All of the files are there just like they should be but the game no longer recognizes the game.
Test Subject
#62 Old 17th Nov 2006 at 1:55 AM
Default All is lost
Um i tried the moving Neighborhood manager thing that was suggested in the previous post. Now the game wont load at all! i get an error message. All is lost! All is lost!
Just east of Lyra, northwest of Pegasus
retired moderator
Original Poster
#63 Old 17th Nov 2006 at 5:28 PM
The whole game will not load? Or still just the corrupt neighbourhood?
Test Subject
#64 Old 17th Nov 2006 at 8:08 PM
Operating system: MAC OS 10.3.9
Computer specs: ibook 1.33 ghz, 512 mb RAM, G4
Games: Sims 2, Uni, NL, OFB, Pets. No patches as far as I remember, and if I do have any it's for base game or Uni.
Details of Neighbourhood loss: Pleasantview is gone, it was the last neighborhood played.
Neighbourhood File details If you go to Documents/ EA Games/ The Sims2/ Neighbourhoods are the neighbourhood files still there? Yes, all intact.
Sim PE Investigation: n/a.
What changed on your system immediately before the corruption: Installed Pets EP. Opened it with custom content enabled, and opened Plesantview. Created two pets in CAS, merged with current household, and played it. One sim with a custom skin tone lost his face after "change appearance" in the mirror. I then did NOT save the lot, and exited the game. When I came back, Pleasantview was gone.

Tried replacing the neighborhood manager and it didn't do anything.
Test Subject
#65 Old 18th Nov 2006 at 11:55 PM
Main problem is all my sim characters and houses are not appearing in my Hood2- Strangetown (and the subneighbourhoods) I play this one the most. They only appear the default sims. (Full details below)

Operating System: WINDOWS XP professional

Computer Specs: 3.01ghz, 1.00gb ram, ATI Radeon 9550

Games: Sims2 CD original, uni, nightlife, pets, open for business. No patches as I'm unaware of.

Details of Hood loss: Recently had to uninstall the Sims2 game, I saved all neighbourhoods (even though I only use Hood2- Strangetown). But when re-installing the Sims2 game and all expansions, and coping all the hoods back into the file they did not show up on the game. Only default sims remained. I lasted played Strangetown (usually also Bluewater Village) a lot.

I did remove ALL downloads and hacks because I had to reinstall Windows XP altogether. But I saved them on my USB drive. I haven’t put downloads back on yet.

Neighbourhood File details: When I click in the folder my backed up files and defualt appear to be there. Seeing as I play Strangetown (hood 2) the most, I noticed my backup files saved are still there and once I played the game with up to 00200.package characters, more .package files started to appear because I started the game and the sub-hoods were creating, making a total of 00513.package. But my Sub-hoods do not contain folders, the files themselves appear as .package (??)

Sim PE Investigation: Don't think so as I had to re-install XP and everything was deleted.

Other option mentioned: I have tried, nothing seems to work or show. Also did vis versa (backed up manager.package) that also didn't work.

Test Subject
#66 Old 21st Nov 2006 at 4:17 AM
OS: Windows XP Pro

SPEC: Intel Core 2 Duo 6600, 2gb Ram, NVIDIA GeForce 7900 GT

I have The Sims 2 plus the first three expansions (I've yet to acquire Pets).

A few days ago I reinstalled the game, it wasn't loading properly after I had a virus corrupted some of my exe files. Silly me forgot to backup all my saved game files and custom content but I was able to recover most of them so I'm not complaining about that.

However, when I try to put my neighbourhood (N005) back into the game it doesn't show up on the list. I checked the files, they're all there and they shouldn't be corrupted (the recovery software wouldn't let me restore files that were messed up and I was careful not to save anything to the drive so they wouldn't be written over).

I've tried creating a new N005 and then copying my old files over that but it doesn't help. I'm not really sure what else to try.
Test Subject
#67 Old 25th Nov 2006 at 4:03 AM
Operating system: Windows XP

Computer specs: Intel Pentium 4 Procesor 530, 524MB RAM, 200GB hard disk, NVidia Geforce 7300 GS

Games: The Sims 2, University, Open for business

Details of neighbourhood loss: I followed the tutorials on customization of neighbourhood, I'd never done that, and they recommended downloading a few hacks. When I tried to move the sims from the bin to the houses, and after building the house, saving them, I could not see neither the house nor the sims from the neighbourhood view. The sims were nowhere to be found. I did it all over again, this time I used the teleport thingy (hack) and used it to teleport the sims that had dissapeared, and they DID show up. I saved it again, went back to the neighbourhood and they had dissapeared again.
I had the same problems with ALL the hoods, both the custumized and the Maxis ones.

I tried to erased the no townies hack, but for some reason, the graphics went crazy and messed everything up, so I just uninstalled it alltogether.

Hacks: teleport, the one to change the hour, the one to create just one npc per type, the one to not create any more townies. (Sorry, I'd erased them by now and I don't know the names for each one, I also know I had just a few more but I can't remember). SimPE investigation: the neighbourhoods were there, but they didn't have any folder inside them (I only know about the custimized ones...I don't know about the maxis ones) just the (whatevername).package

What changed on your system before the corruption: I had erased the dna, sims, and relationships using the SimPe. I had also used the 'deleteallcharachters' cheat in the customized 'hood. I never touched the Maxis 'hoods.

Any other relevant information: After installing "Open for business", I had problems trying to start windows. Although I don't think both issues are related :P
Lab Assistant
#68 Old 26th Nov 2006 at 4:55 AM Last edited by windgirl : 26th Nov 2006 at 5:09 AM.
Default Neighborhood was overwritten
OS Name Microsoft Windows XP Professional
Processor x86 Family 15 Model 2 Stepping 7 GenuineIntel ~2666 Mhz 768MB Ram
NVIDIA GeForce4 Ti 4200 with AGP8X
All games, no stuff packs.

I lost most of my downloads just prior to installing Pets as I accidentally dragged them to backup, instead of copying, then deleted the backup...

I retrived most of my missing custom content by re-downloading everything from all the websites, and deleted everything not working with clean installer.

Hacks - pretty much everything going, except C.lovs, because I'd had problems with those and deleted them. Never had any other conflicts caused by havks before though - been lucky. Never had any serious glitches either.

Each time I got a new EP I deleted neighbourhood 1 and then pasted in the old one I had as a backup. It always worked fine. The other neighbourhoods I always deleted to save space, so I just had my version of N001.

This time a lot of my folders vanished - saved sims, projects etc. My version of N001 totally reverted back to the classic Maxis version, although it now had pets running around. Then my backup couldn't be found...

I gave up on it all, and started using Strangetown. Then today I found my backup, and deleted N001 (which I hadn't touched anyway) and plonked my version back in. All the sims and custom stuff is there, but they have no memories, no jobs, no personality/DNA points,no family relationships - even no marriages among my old sims. They do have interests and likes/dislikes, although they have been re-set at ramdom. The link to the shopping district was also severed, although links to uni and downtown remained. I don't have SimPE and don't know what to do. I was wondering if the neighbourhood manager file is responsible? There was a new one made becuase I started using Strangetown, and I did not put the old one in to replace it. I tried putting it in the N001 folder after it I realised there were problems, but to no avail.
#69 Old 28th Nov 2006 at 2:49 PM
Default Hope I can help
Operating system: Win XP Pro

Computer specs:
1200 MHz Processor, 510MB RAM, RADEON 9200 SE.

Base & University, Asia-Pacifica Edition, University patch

Details of Neighbourhood loss:
I’ve never actually played Strangetown or Pleasantville but I play Veronaville but every neighborhood except for the University disappeared together.

3592 organized files that were never dramatically moved recently. With avatera’s Custom Instrument Hack.

Neighbourhood File details: Yep everything is %100

Sim PE Investigation: I’ve never used SimPE up until now so I’m unfamiliar with it but I do use Sims2Pack Clean Installer.

What changed on your system immediately before the corruption:
I defragment and optimize my computer daily aswell as virus scans. I’ve been burning music off my computer onto DVD so I guess a lot of files have been moved but didn’t involve The Sims 2 folders.

Any other relevant information:
Well I didn’t do anything significant before the error occurred but I was lucky I had a backup to restore and things have been fine since.

haha my post is #69 lol ok I'll grow up
Test Subject
#70 Old 4th Dec 2006 at 5:09 AM Last edited by cecim : 5th Dec 2006 at 6:53 PM.
Hello everyone,

I had to give my two cents after reading that the same problem I have been having with the Sims2 has been happening to other people.

I will answer the information as follows:

Operating System: Mac OS 10.4.8

Computer Specs: 1.5 GHz Powerbook G4 768 MB SDRAM

Games: All Expansion Packs, including Pets.

Details of Neighborhood Loss: Here's where it gets sticky. I experienced small problems on the OFB EP with the names of the neighborhhoods disappearing. But, I typed those in and played the game. However, when I added on Pets, my legacy neighborhood would not load. It was a custom made neighborhood (N004). I did not play Strangetown or the other Maxis neighborhoods.

I did a clean install of the base game and expansion packs. Unfortunately, when the game (with Pets) began to run again, I lost the families in both my Nightlife and base game neighborhoods. The Sims that were created in OFB were also gone as well as their businesses.

I called Aspyr and discussed this with their tech. She told me that there was file corruption. She also told me that the only thing I could do is to reinstall everything, eliminate the plist files connected to the Sims 2 and get rid of all files associated with the game in my computer. After backing up everything, I got rid of all the files.

(I also asked if they were going to make a patch for Pets, she told me that wasn't likely at the moment).

I reinstalled the game. However, all the Sims in the neighborhood still did not show up. However, the lots stayed the same without their perspective families.

I then decided to start afresh with a new neighborhood. After establishing the families and building on the lots, things at first seemed fine. And then, when I accessed CAS to create another family, the game crashed (there had been about ten families in the core neighborhood with none in any other sub-neighborhood). I restarted the game and all the families had disappeared again.

Frustrated, I threw out the new neighborhood and started again. However, this time, the name of the new neighborhood disappeared.

Neighborhood File: All of my custom neighborhood files remained same. Nothing was lost. Everything stayed the same, including the snapshots and the storyline. The Sims, however, will not show up.

SimPE: N/A

What Changed in my system: The only mod I had was the SimCutie espresso machine . However, I have tons of hair, skintones and clothes downloads. I thought at first it might be the level of downloads (I have about 5,000), but the game worked time and time again with the downloads in question.

Neighborhood Manager File Test: I followed the instructions to the letter and nothing different occurred. My lots (after several quits and spans in playing) and families continued to disappear.

The only thing I hope is that there is a patch or some workaround that will help solve this problem. I agree with an earlier poster that it shouldn't be stressful to play a game. However, the Pets expansion pack has caused me a lot of grief. I told this to the techs at Aspyr and they told me that I should reinstall and that would take care of everything. It didn't.

Thank you for opening this thread. I am grateful. I was racking my brains before what I could have done wrong to cause this to happen. And now that other people are experiencing the same problem, I am not alone. I feel comforted.

Take care,

Test Subject
#71 Old 5th Dec 2006 at 5:55 AM Last edited by cecim : 5th Dec 2006 at 6:50 PM.
Default A Small Update
Hello once again,

I have tried some new things in my search to understand this problem with the disappearing Sims and neighborhoods. Unfortunately, I found out more negative news than positive.

1)I upped the file limit to 40000 for my maximum files. When I tried the Sims2 Pets, it still displayed the wireframe neighborhoods and loss of Sims. So, on my end the lack of file space isn't the problem.

2)Because of the lack of solution with the file limit, I tend to think that it has to do with the corruption of files. However, I wonder (if someone can answer this) what causes the file corruption. All of my downloads have worked faithfully and wonderfully until I installed Pets.

3)I wonder if the rumors about Pets being very buggy are true. I have read several different accounts about how the code within the game is buggy and reacts with custom content in both Body Shop and the game. To tell you the truth, I haven't had any problems with Body Shop since I did a clean install of my game and expansion packs. However, I have had tremendous bad luck with the latest expansion pack again and again.

Could anyone elaborate on the situation regarding Pets being buggy for both Macs and PC's?

4)I tend to think that a patch is needed from Maxis (and Aspyr) to address this problem, if the "buggy-ness" of the game is true. Is there any way to convince anyone with the company to listen?

I just wanted to convey some thoughts I have had with the developments regarding my missing Sims and neighborhoods. I still have not played over a week now since I've added Pets. I don't want to blame the latest expansion pack, because I have heard that others have played it perfectly with or without downloads. But, I would like to know if others had played the game perfectly up until Pets.

And also, if there are those who are playing Pets perfectly now how are they able to do so without any problems.

Just my two cents.

Thank you once again for listening and having this thread.

Test Subject
#72 Old 6th Dec 2006 at 4:39 AM Last edited by cecim : 6th Dec 2006 at 4:50 AM.
Default One More Small Update
Firstly, I am very sorry for posting once again. It is just that I am concerned about this problem and that I am just about out of solutions to make my game work.

With that being said, I have a small update on the testing front:

1)I loaded and played the game without a download file (where "corrupting" custom content might be found [i.e., the "control group" of this test]). I added a custom neighborhood and sub-neighborhoods (University, Nightlife and OFB Suburb) and used solely Maxis content. I then quit the game and started it up again without any custom content or Download file to check if the names I typed in would be written and saved as part of the custom neighborhood.

When the game went to the neighborhood screen (where you pick the neighborhood you would like to play), the custom neighborhood I created was missing its name. When loading the neighborhood, all sub-neighborhood names were missing.

That means to me a couple of things:

a)In my case, it isn't the fault of custom meshes or the downloads (as far as I can see).
b)It might be, in my case, the fault of the game code itself. I now believe more and more that the game is buggy and affecting game play. Does anyone else have a different explaination that might help?

2)The Maxis families, btw, did not disappear. The Sims I added (with only Maxis content) disappeared. Their lots mysteriously disappeared.

a)From that, I conclude that there is something that definitely needs to be corrected with a patch (I hope).

Again, I hope that my investigation into this problem helps others in trying to find out what exactly is going on.

Just east of Lyra, northwest of Pegasus
retired moderator
Original Poster
#73 Old 6th Dec 2006 at 6:24 PM
cecim, it does sound as though the game is having trouble writing to the hard disc. Do you have all of the Aspyr patches applied, or just the latest patch, or none at all?
Test Subject
#74 Old 8th Dec 2006 at 1:52 AM Last edited by cecim : 8th Dec 2006 at 2:40 AM.

I have every Aspyr patch installed along with the EP's (Sims2, University and Nightlife; they have not made a patch for OFB or Pets).

However, it is funny that you would say that the game has had a hard time writing to the hard drive. I just had my hard drive upgraded two months ago because the other one broke down.

Speaking of the game having a hard time writing to the hard drive, do think this is a hardware related or code related occurrence?

However, late last night I did a clean install of my game once again. With each expansion pack, I added the neighborhoods in question. By the time it got to OFB (I'm kind of leery of adding Pets right now), every single neighborhood stayed in tact. Not one disappeared. I played OFB and built houses without any problems--with custom content enabled after the clean install was over.

At this point until a patch is created, I am afraid of using the Pets expansion pack because each time I added it on, the game would not run properly due to the disappearing neighborhoods and other occurrences that have happened..

So, I am continually puzzled by the behavior the game.

Thanks for answering my comments.

Take care,

Just east of Lyra, northwest of Pegasus
retired moderator
Original Poster
#75 Old 8th Dec 2006 at 6:13 PM
I did hear on the Mac Help forum that the recommendation is to just apply the patch for the last EP and to uninstall first if other patches were installed... saying that, when you reinstalled, did you remove all plists and receipts from the game? For the disc writing problem I was thinking along the lines of a glitch sometmes seen in PC games, where certain versions of the operating system combined with certain patches seems to cause the game to not have permission to write to the Documents folder. This means that any changes done were lost when the game was exited, which sounds a bit similar to your problem.
Page 3 of 28
Back to top