Replies: 86 (Who?), Viewed: 40498 times.
Page 3 of 4
Lab Assistant
#51 Old 17th Dec 2019 at 11:02 AM
Thanks. I do not change the body in BGEO. I generate it in d maps / with the same standard body that I tried unchanged. I work in MilkShape 3D 1.8.5. It seems to somehow affect the mesh. But I do not know how to work in blender / my obj file
https://vk.com/doc269285286_528856727
Advertisement
Ms. Byte
Original Poster
#52 Old 17th Dec 2019 at 4:28 PM
Quote:
Originally Posted by KarinaRuDICH
Thanks. I do not change the body in BGEO. I generate it in d maps / with the same standard body that I tried unchanged. I work in MilkShape 3D 1.8.5. It seems to somehow affect the mesh. But I do not know how to work in blender / my obj file
https://vk.com/doc269285286_528856727


Your morph is changing the fingers, which causes the appearance of an open mouth. You can't use a DMap on fingers or the inner mouth because they're mapped to the same area in the uv1.

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Lab Assistant
#53 Old 18th Dec 2019 at 8:48 AM
Thank you dear ❤ .
Test Subject
#54 Old 19th Feb 2020 at 2:43 AM
Default symmetry
hi i was wondering if you had any idea for a work around for an issue i’m having with creating presets- when i import the base female mesh into blender as an obj- the mesh is ever so slightly asymmetrical making morphing eyeshapes impossible. with the x mirror or symmetry tool on it can’t work purely because of the asymmetrical base mesh for some reason. i was wondering if there’s a way for morphmaker to read only one side of the morphed obj, and flip it onto the other? thank you for reading and i hope i make sense ?
Ms. Byte
Original Poster
#55 Old 19th Feb 2020 at 10:28 AM
Quote:
Originally Posted by fwoop
hi i was wondering if you had any idea for a work around for an issue i’m having with creating presets- when i import the base female mesh into blender as an obj- the mesh is ever so slightly asymmetrical making morphing eyeshapes impossible. with the x mirror or symmetry tool on it can’t work purely because of the asymmetrical base mesh for some reason. i was wondering if there’s a way for morphmaker to read only one side of the morphed obj, and flip it onto the other? thank you for reading and i hope i make sense ?


No, MorphMaker can't do that. How do you mean it's impossible? Does MorphMaker throw an error when you try to make the BGEO or is the morph distorted? If you're getting an error in MorphMaker only after using the symmetry tool my guess is that Blender is changing the order of the vertices.

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Test Subject
#56 Old 19th Feb 2020 at 8:35 PM
Quote:
Originally Posted by CmarNYC
No, MorphMaker can't do that. How do you mean it's impossible? Does MorphMaker throw an error when you try to make the BGEO or is the morph distorted? If you're getting an error in MorphMaker only after using the symmetry tool my guess is that Blender is changing the order of the vertices.


There's no error when i import it to morph maker, but extracting the base mesh itself from the game and trying to morph it proves very difficult as the actual mesh is asymmetrical. I attached a pic of me trying to morph the sims eye shape, but as you can see, there's an uneven number of vertices on each side of the face, making it impossible to do. For this I simply turned on x mirror and tried to move a vertex on one eye, you would imagine it to be symmetrical but


I also tried to do a similar thing in autodesk maya, yet it still cant read symmetry as the base mesh isnt. So i was wondering if you had a workaround for thi?
Sorry im so bad at explaining things and thanks for replying ^^
Screenshots
Ms. Byte
Original Poster
#57 Old 20th Feb 2020 at 12:05 AM
My best guess is that the mesh isn't exactly symmetrical because of rounding errors or who knows what. MorphMaker just converts it into obj format without changing the vertex positions so there's not much I can do about it.

If it's any help, I was able to turn on x-mirror and topology mirror and use sculpt mode to do symmetrical changes. Just make sure sculpt doesn't add or remove vertices.

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Test Subject
#58 Old 21st Mar 2020 at 3:26 AM
Default Ugly Shading
I just made a cheek preset in Blender and exported it as an obj. file, I made sure all the export settings were properly ticked off and I followed all of the morph maker instructions to get it into The Sims 4, but for some reason when it appears in game there is ugly shadowing all over the whole face. I even tested this with the base male face without making any changes, as soon as it appears in game the ugly shadowing all over the whole face appears. Here's an example:

Without


With:
Screenshots
Ms. Byte
Original Poster
#59 Old 21st Mar 2020 at 3:38 AM
Quote:
Originally Posted by TheEagleWillLand
I just made a cheek preset in Blender and exported it as an obj. file, I made sure all the export settings were properly ticked off and I followed all of the morph maker instructions to get it into The Sims 4, but for some reason when it appears in game there is ugly shadowing all over the whole face. I even tested this with the base male face without making any changes, as soon as it appears in game the ugly shadowing all over the whole face appears. Here's an example:

...


For whatever reason, the normals are getting messed up. I suggest you check the 'Ignore normals' option when making the BGEO and see if that helps.

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Test Subject
#60 Old 21st Mar 2020 at 5:43 AM
Quote:
Originally Posted by CmarNYC
For whatever reason, the normals are getting messed up. I suggest you check the 'Ignore normals' option when making the BGEO and see if that helps.


Just tried it, for some reason if I select "ignore normals" the preset doesn't appear in game at all.
Ms. Byte
Original Poster
#61 Old 21st Mar 2020 at 11:09 AM
Quote:
Originally Posted by TheEagleWillLand
Just tried it, for some reason if I select "ignore normals" the preset doesn't appear in game at all.


Please upload your base and morph meshes and your package that's not showing up in the game.

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Test Subject
#62 Old 5th Apr 2020 at 8:29 AM
Default Update
Sorry it took me so long to respond! I actually managed to fix the problem, I think it wasn't showing up in game because I was using a later version of Blender, 2.79 to be exact. Once I switched to Blender 2.70, the normal's were still getting messed up, but when I checked off ignore normal's that worked just fine! Thank you!
Test Subject
#63 Old 6th Apr 2020 at 5:31 AM
Kind of related, kind of unrelated, but does anyone know how to fix a package group, per example, Zerbu's presets to make all of them have the mermaid and spell casters tags in game? I know how to add the tags individually, but not to a whole group. If there is a way to apply it to a whole group I want to know so that Zerbu's presets will show up in my game for mermaids and spell casters, it'd be a pain to have to do them all individually.
Test Subject
#64 Old 6th Nov 2020 at 4:58 AM
Quote:
Originally Posted by CmarNYC
Interesting project! How did you form the nose? For morphs you can move vertices and change normals but that's all, so you'd have to reshape the nose without adding or removing any vertices or faces. Looking at that error message, it looks like the nose mesh has a face with way more than the three required sides and with no uvs or normals; if so that must have been added.

If all you did was move vertices, please upload your base head obj mesh and the morphed head obj.

Just IMO, but for this project you might be better off making a head replacement that's used as an accessory and removes the standard head.


I am having the same issue with the error message but I did not add/remove any vertices or faces. After clicking "create BGEO" the error message pops up and will not go any further. I've tried several things with my system to see if it'll help, but I'm still having the same problem.
Ms. Byte
Original Poster
#65 Old 6th Nov 2020 at 7:46 AM
Quote:
Originally Posted by ncrandoms
I am having the same issue with the error message but I did not add/remove any vertices or faces. After clicking "create BGEO" the error message pops up and will not go any further. I've tried several things with my system to see if it'll help, but I'm still having the same problem.


Please upload your base and morph meshes.

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Test Subject
#66 Old 29th Nov 2020 at 4:29 PM
I have created an eye preset following the instructions, and it works well in the game as a 3D shape, but it adds a 2D texture to the eyelid depending on the physical characteristics of the sim I'm creating.

I'd like to assign a texture to my preset using the MorphMaker, but I don't know how to do it. You briefly said that it's possible, and I can see the option where it says "Import" (Texture) in the "Add/Edit Sculpt" tab. I also see that it must be a DDS file, but don't know exactly what must it contain to work properly, I have no experience modifiying texture in the game, and I can't find any information on this specific case (face presets).
Ms. Byte
Original Poster
#67 Old 29th Nov 2020 at 9:00 PM
Quote:
Originally Posted by Datodato
I have created an eye preset following the instructions, and it works well in the game as a 3D shape, but it adds a 2D texture to the eyelid depending on the physical characteristics of the sim I'm creating.

I'd like to assign a texture to my preset using the MorphMaker, but I don't know how to do it. You briefly said that it's possible, and I can see the option where it says "Import" (Texture) in the "Add/Edit Sculpt" tab. I also see that it must be a DDS file, but don't know exactly what must it contain to work properly, I have no experience modifiying texture in the game, and I can't find any information on this specific case (face presets).


The textures are grayscale overlays. Why don't you clone a game eye sculpt and export the texture to use as an example?

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Test Subject
#68 Old 30th Nov 2020 at 1:00 AM
Does anyone have an UPDATED MCD? I have 200+ mods so going one by one is definitely NOT an option for me. But all the MCDs ive been finding havent been updated in almost an year. It wasnt until the last game update that my game has started acting up. The kids wont go to school or do their homework, I have to physically click the "go to school" button about 3-4 times before they actually go, and no matter how many times I click the homework for them to do it, they sit down open the book and then close it immediately. can someone PLEASE help !!!! I need an UPDATED MCD please
Blenderized to Pieces
retired moderator
#69 Old 30th Nov 2020 at 7:28 AM
Quote:
Originally Posted by Jantayw96
Does anyone have an UPDATED MCD? I have 200+ mods so going one by one is definitely NOT an option for me. But all the MCDs ive been finding havent been updated in almost an year. It wasnt until the last game update that my game has started acting up. The kids wont go to school or do their homework, I have to physically click the "go to school" button about 3-4 times before they actually go, and no matter how many times I click the homework for them to do it, they sit down open the book and then close it immediately. can someone PLEASE help !!!! I need an UPDATED MCD please
Hello,  Sorry,  I don't know what the initials MCD stand for. If everything you find is out of date, just troubleshoot the old fashioned way.  Divide your CC in two and test each half.  Then test the other half.  Divide as you go to narrow the problem CC down.  It's faster than testing each one individually.

The stuff with Rigs and Actions are most likely the ones giving you problems.  Simple decor objects rarely give issues.  Look at your scripts, cheats, chairs, canning stations, anything that involves opening and closing, packages, etc. That will help you narrow it down.  Good luck.  
Test Subject
#70 Old 30th Nov 2020 at 3:33 PM
Quote:
Originally Posted by CmarNYC
The textures are grayscale overlays. Why don't you clone a game eye sculpt and export the texture to use as an example?


Thank you! That is exactly what I needed, and I didn't know it was possible until you said it. But now that I've tryed it an error happens when I export the texture: "Could not write file", "Object reference not set to an instance of an object".

Screenshots
Ms. Byte
Original Poster
#71 Old 30th Nov 2020 at 7:17 PM
Quote:
Originally Posted by Datodato
Thank you! That is exactly what I needed, and I didn't know it was possible until you said it. But now that I've tryed it an error happens when I export the texture: "Could not write file", "Object reference not set to an instance of an object".



Crap, that's because EA in their infinite wisdom converted the overlays to the new LRLE format we can't read in a recent patch. I'm working now on getting MorphMaker to find the old versions of these textures, and will have to provide the toddler textures myself since there's no old version available. Meanwhile, here's several eye overlays for you to use. Importing a new one should work okay.
Download - please read all instructions before downloading any files!
File Type: zip TS4EyeOverlays.zip (557.2 KB, 4 downloads)

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Test Subject
#72 Old 30th Nov 2020 at 10:47 PM
Quote:
Originally Posted by CmarNYC
Crap, that's because EA in their infinite wisdom converted the overlays to the new LRLE format we can't read in a recent patch. I'm working now on getting MorphMaker to find the old versions of these textures, and will have to provide the toddler textures myself since there's no old version available. Meanwhile, here's several eye overlays for you to use. Importing a new one should work okay.


I've been experimenting and I've used the textures you uploaded (thanks again), but even when I import them to my sculpt without any modification the game doesen't show them. Everything seems correct in MorphMaker and it's previews, but then the game only shows the modified 3D structure and it adds a default texture over it. Can it be due to the new patch you mentioned?

Screenshots
Ms. Byte
Original Poster
#73 Old 30th Nov 2020 at 10:59 PM
Quote:
Originally Posted by Datodato
I've been experimenting and I've used the textures you uploaded (thanks again), but even when I import them to my sculpt without any modification the game doesen't show them. Everything seems correct in MorphMaker and it's previews, but then the game only shows the modified 3D structure and it adds a default texture over it. Can it be due to the new patch you mentioned?


Please upload your package so I can take a look.

It's possible - certainly if it's a default replacement the game will find the LRLE version and use that first. There's a workaround, you can change the type ID of the texture to 0x2BC04EDF to trick the game. I'd like to do some testing on your package.

Edit: Are you sure the texture isn't showing? Did you test by putting a black spot or something on it?

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Test Subject
#74 Old 1st Dec 2020 at 12:03 AM
Quote:
Originally Posted by CmarNYC
Please upload your package so I can take a look.

It's possible - certainly if it's a default replacement the game will find the LRLE version and use that first. There's a workaround, you can change the type ID of the texture to 0x2BC04EDF to trick the game. I'd like to do some testing on your package.

Edit: Are you sure the texture isn't showing? Did you test by putting a black spot or something on it?


It's weird, I've just put a black line on a copy of the texture used before, then replaced it in the package, then saved the package with a different name and now it appears in the game. As you can notice in the images, before painting the line the texture showed in the game was completely different, it was being replaced by a default texture or something.

Well, I guess the problem is solved, even though I don't know what was going on...

Screenshots
Ms. Byte
Original Poster
#75 Old 1st Dec 2020 at 12:11 AM
Quote:
Originally Posted by Datodato
It's weird, I've just put a black line on a copy of the texture used before, then replaced it in the package, then saved the package with a different name and now it appears in the game. As you can notice in the images, before painting the line the texture showed in the game was completely different, it was being replaced by a default texture or something.

Well, I guess the problem is solved, even though I don't know what was going on...



If you used the default name possibly it made it a default replacement and changing the name fixed it? I'll have to check the code but I don't think that's likely. Anyway, glad it's working!

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Page 3 of 4
Back to top