Replies: 28 (Who?), Viewed: 19634 times.
Page 2 of 2
Lab Assistant
#26 Old 16th May 2022 at 11:55 PM
Quote:
Originally Posted by PacMani
Just dropping by to say 5.1 works fine for me

What system and graphic card do you have?
Does 5.1 run more smoothly compared to 4.9.1?
Advertisement
Test Subject
Original Poster
#27 Old 28th May 2022 at 8:53 AM
Quote:
Originally Posted by PineappleForest
Reshade 5 is out now - IT WON'T WORK for TS2. Edit: it seems to work sometimes.
I couldn't make it work at all and I know other ppl also have issues with it, so I still I recommend version 4.9.1

It took me a while to figure out how to make DoF (depth of field effect) and AO (ambient occlusion) in Reshade work, so I though I'd share what I've found.
(It won't work for everybody, that's for sure )

I'm on Win10, Geforce GTX 1050 Ti, UC (that one particular version of UC that's missing IKEA files ;P ). I've installed Reshade using Vulkan & DXVK without issues,
even though I should've read this documentation first !.
And if you're about to install DXVK, you should read it (author of this tutorial didn't stress it enough IMO).

I applied all tweaks that were supposed to make DoF work properly, but no, it didn't work. When I tried to tweak Reshade buffer settings, I got some patchy, random blurriness.
Then I dropped Pine's custom post effects mod (SSAO version) ) in my Downloads. Both DoF and AO in Reshade started working.
You don't need to enable their mod via console, you just need to have the files. And also: read the instructions!
Unfortunately, as I discovered, Pine's mod has the potential to cause pink flashing. That's pretty clear in my case, I never got pink before I dropped that mod in my Downloads.
But it can give me DoF, so I'll keep using it . I'm usually able to take a whole bunch of pretty screenshots before I start getting pink.
When it happens, I remove the mod. Sometimes I still get a bit of pink when I run the game again (and that's weird) but eventually my game goes back to normal.
(If you're still getting pink after removing Pine's mod, you might try to delete .dxvk-cache file )

To make Reshade's DoF work, I needed to edit global preprocessor definitions. Here's my configuration.


And here are Vulkan buffer settings that work for me.
I only need to tweak it for Hood view.


Maybe somebody will find that useful.

ReShade 5.2 came out recently and the way it gets injected to Vulkan applications got changed again, this time it's once again global like in 4.x with the difference that it won't inject into a Vulkan program if in the location of it's executable there's no ReShade.ini file. So it means that if you have a ReShade.ini in your Sims 2 installation it will inject without an issue if you're using DXVK.
Lab Assistant
#28 Old 1st Jun 2022 at 2:38 PM
@supra107
Thanks for the info!
Good to know that it works, but I'd love to know if it's actually better for TS2 than 4.9?
The main issue I have with 4.9 is that transparent textures like thin grass leaves basically disappear when I zoom out.
Field Researcher
#29 Old 6th Aug 2022 at 5:04 PM
I notice when I do that seti & Dirty Rect thing it makes my game flickr.
Page 2 of 2
Back to top