Replies: 3 (Who?), Viewed: 311 times.
Test Subject
Original Poster
#1 Old 14th Feb 2021 at 8:28 PM
Default Custom rabbit hole doors not moving/opening
Hello peeps!

Does any of you ever successfully made rabbit hole in wich everything worked properly? I recently started making one for my custom world, (by cloning EA's, replacing mesh, textures, changing type from grocery to bistro) and everything looks fine, except for doors. They're not opening, and sims are walking through them when entering building.

I searched for some tips on internet, but all i found was few old, dead links and some very vague informations.

Could someone help me with this? Thanks!
Advertisement
Virtual gardener
staff: administrator
#2 Old 17th Feb 2021 at 1:07 PM
Well the doors bit would need bones of course, else the game doesn't have anything to animate on  

Now this is showing it on clothing, but I personally do this the same way with objects as well: https://www.youtube.com/watch?v=2-mwKIrxWLw

Hope this helps!
Forum Resident
#3 Old 17th Feb 2021 at 7:27 PM
When creating a custom rabbit hole in TSR Workshop I simply figured out which group the door mesh is. Then in Milkshape I replaced all groups BUT the door and moved the whole structure to fit the default door. Sometimes I needed to shorten or lengthen the door to avoid clipping. You can apply a custom texture to the default door, but you have to edit the UV map in most cases.
Test Subject
Original Poster
#4 Old 22nd Feb 2021 at 8:40 PM
Well, bones were the problem. Turns out, that I haven't assigned them properly. But I managed to make everything work. Thanks! :D
Back to top