Replies: 3 (Who?), Viewed: 91 times.
Field Researcher
Original Poster
#1 Old 11th Oct 2021 at 12:22 PM Last edited by Kestin : 11th Oct 2021 at 2:50 PM.
Default Shoeswapping - solved
A few weeks ago, I tried shoeswapping a dress to have bare feet. Seems simple, right?...I gave up then, but now I want to see if I can fix what I was doing wrong, so that I can do this in the future. I got lost on step 13 of this tutorial, where it says "Select two vertices that should be matched up, one from the top, one from the bottom" -- I don't know what it means by the "top" and "bottom", though I'm guessing it means the two different meshes. I guess the problem is that here's what I had at that point; the line where the meshes meet is highlighted. (Sorry for the large images.)





(Also possibly notable is this weird crease here, which seems to not be at the spot where the two meshes meet up. This part is just the Maxis nude mesh. Is it just messed up like that and I never noticed?)



I tried to continue by selecting what I could see, which to my view was just one vertex, but I hoped it was actually two (one from each group) that were just too well aligned to tell apart. I couldn't find an option for "Extended Manual Edit", but I figured regular old "Manual Edit" was the same thing. When I tried using it, it said I had selected two vertices that were already completely identical*, which I guess would be great but the mesh number was the same so I think they were from the same group to start with. I wasn't sure what to do, so I just did Manual Edit and clicked OK for each vertex/pair/whatever they are. Nothing seemed to actually happen. I also tried the technique from this tutorial, with data merging, but I'm pretty sure that also did nothing.

*The one time they weren't, it wouldn't let me actually change any of the numbers. It just reverted back to what it started as. This is probably also me doing something wrong.

...I then couldn't find "Align Normals" in the menu, and that step looked pretty important, so at that point I surrendered and put the whole thing away. Any advice on how to continue from here? I am using Milkshape version 1.8.4 (free trial) with Wes Howe's Sims 2 plugins.

UPDATE:

After I found the Extended Manual Edit and Align Normals plugins, I was able to continue and get a finished product...but the finished product is weird-looking, as seen below, and I'm not sure what I did wrong.


pronouns: they/them
Advertisement
Mad Poster
#2 Old 11th Oct 2021 at 12:46 PM
Have you done anything very time-consuming to the meshes you want to keep? If not, scrap this try, make sure "Autosmooth" is unticked under "Groups" in Milkshape, then import the meshes again. Autosmooth is why you're getting the extra creases (you can see it on the rest of the foot, too) - it's the normals having been messed up.

It's going to be much easier when you have Autosmooth turned off, since you'll only have that one line on each leg to fix, and can follow the tutorial.

"Align normals" is under "Edit", but don't use it unless you absolutely have to. It can cause a bit of a mess unless you use it correctly, because it smooths everything that's selected, and doesn't take into account creases you want to keep unless you select and smooth parts in a particular way.
Field Researcher
Original Poster
#3 Old 11th Oct 2021 at 1:04 PM Last edited by Kestin : 11th Oct 2021 at 1:33 PM.
Quote:
Originally Posted by simmer22
Have you done anything very time-consuming to the meshes you want to keep? If not, scrap this try, make sure "Autosmooth" is unticked under "Groups" in Milkshape, then import the meshes again. Autosmooth is why you're getting the extra creases (you can see it on the rest of the foot, too) - it's the normals having been messed up.

It's going to be much easier when you have Autosmooth turned off, since you'll only have that one line on each leg to fix, and can follow the tutorial.

"Align normals" is under "Edit", but don't use it unless you absolutely have to. It can cause a bit of a mess unless you use it correctly, because it smooths everything that's selected, and doesn't take into account creases you want to keep unless you select and smooth parts in a particular way.


Autosmooth is indeed checked. I'll try unchecking it. That sounds like it should make a big difference; I'll report back.

EDIT: Eureka! Just what I wanted. Thank you so much! (Why is it always these tiny random details that make or break the whole thing? Why didn't the tutorial mention it? Oh well. Now I know!)

pronouns: they/them
Mad Poster
#4 Old 11th Oct 2021 at 3:23 PM
It is mentioned in the 3rd Unimesh tutorial (which also is a shoeswap tutorial), here:
https://modthesims.info/wiki.php?ti..._-_wiki_version
It's possible the issue is most problematic when you import in more than one mesh, but it's best to leave the box unticked at all times just to be safe.

It's easy to forget things when making a tutorial. Most people who use Milkshape probably have Autosmooth permanently turned off. It's one of those issues you often deal with once or twice when starting out and then know how to solve, so it mostly sticks out when people stumble across it for the first time, or it's been ages since they made a mesh and have to set up Milkshape again.
Back to top