Replies: 5 (Who?), Viewed: 5527 times.
Lab Assistant
Original Poster
#1 Old 23rd Nov 2015 at 10:49 PM
Default Sims 3 Package Viewer Error: The Given Key was not Present in the Dictionary
Why yes, I am still playing Sims 3!

I have a butt-ton of custom content, and every now and again I like to go through the files and cull them. I use Sims 3 Package Viewer for this; it shows the thumbnails and is an indespensable tool for me. Only now it's not working. I get an error message that looks like this:



I recently upgraded to Windows 10. Could that be the problem? I tried to run it in compatible mode with Windows 7, but with no luck. I'm stumped on this.
Advertisement
Virtual gardener
staff: administrator
#2 Old 24th Nov 2015 at 2:29 PM
Hey mirabellarose!

Does this happen to you when you click on all your packages, or just one? there are many reasons why it could act this way, like instead of a TS3 package it could be a TS4 or TS2 package. Even this happens to me, though when accidentally putting a sims 4 CC in your game, your game won't even start.
The problem can also be a outdated package (Yup even one of these still exists) or a corrupted package. I don't really know how it acts with packages that were made with TSRW, since I know that Delphy's Dashboard sees packages that were made with TSRW, as a corrupted package, which it is not.
Lab Assistant
Original Poster
#3 Old 26th Nov 2015 at 11:37 PM
Quote:
Originally Posted by Greenplumbbob
Hey mirabellarose!

Does this happen to you when you click on all your packages, or just one? there are many reasons why it could act this way, like instead of a TS3 package it could be a TS4 or TS2 package. Even this happens to me, though when accidentally putting a sims 4 CC in your game, your game won't even start.
The problem can also be a outdated package (Yup even one of these still exists) or a corrupted package. I don't really know how it acts with packages that were made with TSRW, since I know that Delphy's Dashboard sees packages that were made with TSRW, as a corrupted package, which it is not.


I know these files aren't Sims 4 files. I've had them for a long time, even before Sims 4 came out. Plus I've had them in my game. AND I checked them with Delphy's Dashboard just to make sure. Actually, I'm wondering if the problem is my graphics card. Lately I've been having a lot of problems with my card. It's been overheating, making my monitor shut down suddenly, and now this:



Do you think it could be my card that's the problem? Unfortunately, I can't afford to replace my card until January at the earliest, so I won't know if it's my card causing the problem with the package viewer until then.
Virtual gardener
staff: administrator
#4 Old 27th Nov 2015 at 2:37 PM
Quote:
Originally Posted by mirabellarose
I know these files aren't Sims 4 files. I've had them for a long time, even before Sims 4 came out. Plus I've had them in my game. AND I checked them with Delphy's Dashboard just to make sure. Actually, I'm wondering if the problem is my graphics card. Lately I've been having a lot of problems with my card. It's been overheating, making my monitor shut down suddenly, and now this:



Do you think it could be my card that's the problem? Unfortunately, I can't afford to replace my card until January at the earliest, so I won't know if it's my card causing the problem with the package viewer until then.


Hmm... It does look like some graphic problem, but is this with every object in the game? I mean literally everything that is an object or sim? I have no idea if updating your graphics card works but I guess it could be you Graphics card making it look like this. If you already encountered problems with it at least. Like, crashes and stuff in your own computer.
You could try to lower down your settings and take out any HQ mod if you do, but I don't know if that will really affect anything, since you were talking about overheating and stuff, I guess this could be the only thing that could make it less.
Test Subject
#5 Old 20th Sep 2018 at 2:04 PM
Did anyone figure out the problem? I just so happened and recently download it and I keep getting the same error.
My computer is pretty much Window 10 and sims are up to date, I don't know what else to do.
Test Subject
DELETED POST
26th Jun 2020 at 4:57 PM
This message has been deleted by melqui1.
Test Subject
#6 Old 26th Jun 2020 at 4:58 PM
I have the same problem, does anyone know how to solve it?
Back to top