Replies: 2 (Who?), Viewed: 236 times.
Field Researcher
Original Poster
#1 Old 18th Jan 2022 at 11:28 AM Last edited by Camkitty : 18th Jan 2022 at 11:56 AM.
Default Child Werewolf Animation Conversion Issue
So, I am trying to make a mod to enable the werewolf 'Hunt' interaction for child sims, and make a child version of the adult animation 'a_werewolf_huntSniff_x' so that the child sims will not stretch when they hunt.
I'm having a very weird issue with this.

I've already edited the ITUN to allow child sims to use the interaction, and that works fine. I've also already made a converted version of the huntSniff animation that makes the kids not stretch, and named it with the correct naming convention as 'c_werewolf_huntSniff_x'. I followed this tutorial for converting the animation: https://youtu.be/EmHLZa3GxWE

However! When I try the interaction in-game, the child sims still stretch to use the adult version of the animation, and I cannot figure out why.
The converted child version of the animation plays fine with the animation player mod, and it imports and exports fine in blender. As far as I can tell, it should be working, but its not.

I feel like I must be missing some crucial step, but cannot for the life of me figure out what. It's as if the game is not recognizing the animations as being different versions of the same animation.
I am attaching my package to this post. If anyone can help it would be much appreciated!
Download - please read all instructions before downloading any files!
File Type: zip ChildWerewolf_Hunt.zip (128.6 KB, 2 downloads)
Advertisement
Forum Resident
#2 Old 18th Jan 2022 at 4:04 PM
Hey there! It seems you haven't matched the group number to the expansion pack, which is most probably causing the issue here. In s3pe, open the resource details of the animation and change the group number from 0x00000000 to 0x70000000 (which is Supernatural). Every expansion pack has it's own group number for its animations and most of the time if you don't match the animations to the number the game it won't work. I hope this fixed the problem!

- When one gets inspired by the other, the one inspires another - Anything is Possible.

My Discord server (mainly Sims but other games are welcome too) ---> https://discord.gg/tvrTafF
You can download a lot of my custom animations (for TS3) on my Twitter ---> https://twitter.com/SweetSavanita
Field Researcher
Original Poster
#3 Old 18th Jan 2022 at 11:20 PM
Quote:
Originally Posted by TheSweetSimmer
Hey there! It seems you haven't matched the group number to the expansion pack, which is most probably causing the issue here. In s3pe, open the resource details of the animation and change the group number from 0x00000000 to 0x70000000 (which is Supernatural). Every expansion pack has it's own group number for its animations and most of the time if you don't match the animations to the number the game it won't work. I hope this fixed the problem!


Thank you so much! I fixed the group number and its working perfectly now!! :D
Back to top